# CVE-2026-45783: libp2p: Unvalidated PUT_VALUE records allow unbounded disk exhaustion on DHT server nodes

> Remote attackers can exhaust disk space on libp2p DHT server nodes by sending unvalidated PUT_VALUE messages, causing denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2026
- **Updated:** 11 Jun 2026
- **Also known as:** GHSA-32mq-hpph-xfvr

## What is CVE-2026-45783?

CVE-2026-45783 is a high-severity denial of service vulnerability in js-libp2p, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

libp2p is a JavaScript Implementation of libp2p networking stack. Prior to version 16.2.6, an unauthenticated remote peer can exhaust the disk storage of any @libp2p/kad-dht node running in server mode by sending an unbounded stream of PUT_VALUE messages whose keys bypass all content validation. No credentials, no prior relationship, and no protocol deviation beyond a crafted key are required. The victim node's datastore fills until the host disk is exhausted, making the node unavailable. This issue has been patched in version 16.2.6.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-45783?

2 open source packages ship an affected version, including @libp2p/kad-dht.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@libp2p/kad-dht` | npm | All versions | 16.2.6 |
| `@libp2p/kad-dht` | npm | All versions | 16.2.6 |

## How do I fix CVE-2026-45783?

Upgrade @libp2p/kad-dht to 16.2.6 or later.

## Is CVE-2026-45783 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45783 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45783 and fix it if it is affected.

What it is: CVE-2026-45783 is a high-severity denial of service vulnerability in js-libp2p, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45783 exists.

Affected packages and fixed versions:
- @libp2p/kad-dht (npm): affected all versions; fixed in 16.2.6
- @libp2p/kad-dht (npm): affected all versions; fixed in 16.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45783/ (Markdown: https://insights.sbomify.com/CVE-2026-45783/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45783
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45783
- OSV: https://osv.dev/vulnerability/CVE-2026-45783

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45783/
Summaries are generated and may contain mistakes; the official description above is the record.
