CVE-2026-45784 rust-openssl: Potential out-of-bounds write in `CipherCtxRef::cipher_update_inplace` for AES-KW-PAD ciphers
An out-of-bounds write in rust-openssl allows attackers to cause heap corruption and potentially execute code via crafted AES-KW-PAD inputs.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-45784?
CVE-2026-45784 is a medium-severity memory corruption vulnerability in rust-openssl, published on 17 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
rust-openssl provides OpenSSL bindings for the Rust programming language. From 0.10.50 until 0.10.80, CipherCtxRef::cipher_update_inplace in openssl/src/cipher_ctx.rs incorrectly sized output buffers when used with AES key-wrap-with-padding ciphers EVP_aes_{128,192,256}_wrap_pad. For a non-multiple-of-8 input, OpenSSL writes up to 7 bytes past the end of the caller's buffer or Vec, producing attacker-controllable heap corruption when the plaintext length is attacker-influenced. This issue is fixed in version 0.10.80.
Which versions are affected by CVE-2026-45784?
2 open source packages ship an affected version, including openssl. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
openssl crates.io | From 0.10.50 | 0.10.80 |
openssl crates.io | From 0.10.50 | 0.10.80 |
Linux distribution packages (3)
himmelblau SUSE:Linux Enterprise Server 16.0 | All versions | 2.3.14+git0.e23b4c54-160000.1.1 |
himmelblau SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 2.3.14+git0.e23b4c54-160000.1.1 |
himmelblau openSUSE:Leap 16.0 | All versions | 2.3.14+git0.e23b4c54-160000.1.1 |
Products include Sfackler Openssl.
How do I fix CVE-2026-45784?
Upgrade openssl to 0.10.80 or later.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2026-45784 being exploited?
There is no known exploitation of CVE-2026-45784 in the wild and no public exploit code.
Other vulnerabilities in rust-openssl
Sources
Also known as AZL-92456, DEBIAN-CVE-2026-45784, GHSA-phqj-4mhp-q6mq, MINI-2x6v-9q8v-x9j9, MINI-7xf8-vj97-53x3, MINI-9j34-wmq5-qx94 and 9 more.