{"answers":{"affected":"2 open source packages ship an affected version, including electerm. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-45787 in the wild and no public exploit code.","fix":"Upgrade electerm to 3.9.5 or later.","what":"CVE-2026-45787 is a medium-severity vulnerability in electerm, published on 28 May 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-45787 and fix it if it is affected.\n\nWhat it is: CVE-2026-45787 is a medium-severity vulnerability in electerm, published on 28 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-45787 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- electerm (npm): affected all versions; fixed in 3.9.5\n- electerm (npm): affected all versions; fixed in 3.9.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-45787/ (Markdown: https://insights.sbomify.com/CVE-2026-45787/index.md)","id":"CVE-2026-45787","markdown":"https://insights.sbomify.com/CVE-2026-45787/index.md","name":"CVE-2026-45787","record":{"aliases":["GHSA-g29v-q6h7-76wh"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"terminal client","requires_auth":"low_privilege","summary":"Attackers can decrypt synced bookmarks and modify configuration data due to weak encryption settings in the electerm terminal client.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"electerm","vendor":"electerm_project"}],"cvss":{"score":6,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-759","name":"Use of a One-Way Hash without a Salt"},{"id":"CWE-916","name":"Use of Password Hash With Insufficient Computational Effort"},{"id":"CWE-353","name":"Missing Support for Integrity Check"},{"id":"CWE-329","name":"Generation of Predictable IV with CBC Mode"},{"id":"CWE-326","name":"Inadequate Encryption Strength"}],"description":"electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. Prior to 3.9.5, deterministic AES-192-CBC with a fixed zero IV, constant KDF salt, and no MAC leads to confidentiality and integrity failures for synced bookmark/profile data. Attackers can crack common passwords across installs and perform undetected ciphertext bit-flips to alter config/bookmarks. This vulnerability is fixed in 3.9.5.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"electerm's encrypt method not safe enough","id":"CVE-2026-45787","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"weak_cryptography","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Discourse: Secure uploads exposed by hotlinked image copying","id":"CVE-2026-45788"},"packages":[{"ecosystem":"npm","fixed":["3.9.5"],"introduced":["0"],"last_affected":[],"package":"electerm","purl":null,"source":"GHSA-g29v-q6h7-76wh"},{"ecosystem":"npm","fixed":["3.9.5"],"introduced":["0"],"last_affected":[],"package":"electerm","purl":"pkg:npm/electerm","source":"GHSA-g29v-q6h7-76wh"}],"prev":{"headline":"OpenMcdf: Uncatchable infinite loop in DirectoryTree.TryGetDirectoryEntry on crafted CFB directory cycle","id":"CVE-2026-45785"},"products":["electerm"],"published":"2026-05-28","related":[{"cvss_score":9.8,"headline":"electerm has Command Injection Vulnerability via runMac function","id":"CVE-2026-41500","kev_date_added":null,"published":"2026-05-08"},{"cvss_score":9.8,"headline":"electerm has Command Injection Vulnerability via runLinux function","id":"CVE-2026-41501","kev_date_added":null,"published":"2026-05-08"},{"cvss_score":9.8,"headline":"electerm allows unauthorized users to execute arbitrary commands","id":"CVE-2020-23256","kev_date_added":null,"published":"2023-01-20"},{"cvss_score":9.6,"headline":"Unvalidated shell.openExternal in electerm allows arbitrary protocol execution via terminal link click","id":"CVE-2026-43941","kev_date_added":null,"published":"2026-05-08"},{"cvss_score":9.4,"headline":"electerm: dangerous code can be run through links or command line","id":"CVE-2026-43944","kev_date_added":null,"published":"2026-05-08"},{"cvss_score":9.3,"headline":"electerm: Local code through electerm's single-instance socket","id":"CVE-2026-45353","kev_date_added":null,"published":"2026-05-28"},{"cvss_score":8.4,"headline":"electerm: Path traversal in electerm runWidget leads to arbitrary code execution","id":"CVE-2026-43940","kev_date_added":null,"published":"2026-05-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-29","vendors":["electerm"]},"summary":"Attackers can decrypt synced bookmarks and modify configuration data due to weak encryption settings in the electerm terminal client.","url":"https://insights.sbomify.com/CVE-2026-45787/"}