# CVE-2026-45787: electerm's encrypt method not safe enough

> Attackers can decrypt synced bookmarks and modify configuration data due to weak encryption settings in the electerm terminal client.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 May 2026
- **Updated:** 29 May 2026
- **Also known as:** GHSA-g29v-q6h7-76wh

## What is CVE-2026-45787?

CVE-2026-45787 is a medium-severity vulnerability in electerm, published on 28 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. Prior to 3.9.5, deterministic AES-192-CBC with a fixed zero IV, constant KDF salt, and no MAC leads to confidentiality and integrity failures for synced bookmark/profile data. Attackers can crack common passwords across installs and perform undetected ciphertext bit-flips to alter config/bookmarks. This vulnerability is fixed in 3.9.5.

Weakness: CWE-759 (Use of a One-Way Hash without a Salt), CWE-916 (Use of Password Hash With Insufficient Computational Effort), CWE-353 (Missing Support for Integrity Check), CWE-329 (Generation of Predictable IV with CBC Mode), CWE-326 (Inadequate Encryption Strength)

## Which versions are affected by CVE-2026-45787?

2 open source packages ship an affected version, including electerm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `electerm` | npm | All versions | 3.9.5 |
| `electerm` | npm | All versions | 3.9.5 |

Products: Electerm Project Electerm.

## How do I fix CVE-2026-45787?

Upgrade electerm to 3.9.5 or later.

## Is CVE-2026-45787 being exploited?

There is no known exploitation of CVE-2026-45787 in the wild and no public exploit code.

## Other vulnerabilities in electerm

- [CVE-2026-41500](https://insights.sbomify.com/CVE-2026-41500/): electerm has Command Injection Vulnerability via runMac function (critical 9.8)
- [CVE-2026-41501](https://insights.sbomify.com/CVE-2026-41501/): electerm has Command Injection Vulnerability via runLinux function (critical 9.8)
- [CVE-2020-23256](https://insights.sbomify.com/CVE-2020-23256/): electerm allows unauthorized users to execute arbitrary commands (critical 9.8)
- [CVE-2026-43941](https://insights.sbomify.com/CVE-2026-43941/): Unvalidated shell.openExternal in electerm allows arbitrary protocol execution via terminal link click (critical 9.6)
- [CVE-2026-43944](https://insights.sbomify.com/CVE-2026-43944/): electerm: dangerous code can be run through links or command line (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45787 and fix it if it is affected.

What it is: CVE-2026-45787 is a medium-severity vulnerability in electerm, published on 28 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-45787 in the wild and no public exploit code.

Affected packages and fixed versions:
- electerm (npm): affected all versions; fixed in 3.9.5
- electerm (npm): affected all versions; fixed in 3.9.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45787/ (Markdown: https://insights.sbomify.com/CVE-2026-45787/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45787
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45787
- OSV: https://osv.dev/vulnerability/CVE-2026-45787

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45787/
Summaries are generated and may contain mistakes; the official description above is the record.
