CVE-2026-45788 Discourse: Secure uploads exposed by hotlinked image copying
Attackers can expose secure uploads via hotlinked image copying if the secure_uploads setting is enabled, requiring an upgrade to Discourse.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-45788?
CVE-2026-45788 is a medium-severity vulnerability in Discourse Discourse, published on 9 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Discourse is an open-source discussion platform. Prior to 2026.6.0, 2026.5.1, 2026.4.2, and 2026.1.5, secure uploads could be exposed by pull_hotlinked_images when an attacker knew the secured upload URL and the secure_uploads site setting was enabled. This issue is fixed in versions 2026.6.0, 2026.5.1, 2026.4.2, and 2026.1.5.
Weakness: CWE-200
Which versions are affected by CVE-2026-45788?
1 open source package ship an affected version, including discourse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
discourse Bitnami | From 2026.1.0 | 2026.1.5, 2026.4.2, 2026.5.1 |
Products include Discourse Discourse.
How do I fix CVE-2026-45788?
Upgrade discourse to a fixed version for your release line: 2026.1.5, 2026.4.2 or 2026.5.1.
Is CVE-2026-45788 being exploited?
There is no known exploitation of CVE-2026-45788 in the wild and no public exploit code.
Other vulnerabilities in Discourse Discourse
- CVE-2021-41163 RCE via malicious SNS subscription payload
- CVE-2022-36066 Discourse vulnerable to RCE via admins uploading maliciously zipped file
- CVE-2022-39356 Discourse user account takeover via email and invite link
- CVE-2023-22468 Discourse vulnerable to Cross-site Scripting in local oneboxes
- CVE-2026-27934 Discourse leaks private topic title and post excerpt via user action API endpoint
Sources
Also known as BIT-discourse-2026-45788, GHSA-3876-w96v-8v38.