CVE-2026-45793 Composer: Github Actions issued GITHUB_TOKEN disclosure in GitHub Actions logs
Composer may leak GitHub Actions GITHUB_TOKEN values into CI logs when token validation fails due to regex restrictions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-45793?
CVE-2026-45793 is a high-severity vulnerability in composer, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Composer is a dependency Manager for the PHP language. Prior to 1.10.28, 2.2.28, and 2.9.8, Composer\IO\BaseIO::loadConfiguration() validates GitHub OAuth tokens with the regex ^[.A-Za-z0-9_]+$ and interpolates rejected tokens into an UnexpectedValueException; GitHub Actions GITHUB_TOKEN values using the ghs_<id>_<base64url-JWT> format can contain -, fail validation, and be disclosed to stderr or CI logs. This issue is fixed in versions 1.10.28, 2.2.28, and 2.9.8.
Weakness: CWE-200
Which versions are affected by CVE-2026-45793?
7 open source packages ship an affected version, including composer/composer and composer.
| Package | Affected | Fixed in |
|---|---|---|
composer/composer Packagist | From 1.0 | 1.10.28 |
composer/composer Packagist | From 1.0 | 1.10.28 |
composer/composer Packagist | From 2.0.0 | 2.2.28 |
composer/composer Packagist | From 2.0.0 | 2.2.28 |
composer/composer Packagist | From 2.3.0 | 2.9.8 |
composer/composer Packagist | From 2.3.0 | 2.9.8 |
1 more packages
composer Bitnami | From 1.0.0 | 1.10.28, 2.2.28, 2.9.8 |
Linux distribution packages (1)
php-composer2 openSUSE:Tumbleweed | All versions | 2.10.2-2.1 |
How do I fix CVE-2026-45793?
Upgrade composer/composer to a fixed version for your release line: 1.10.28, 2.2.28 or 2.9.8.
Is CVE-2026-45793 being exploited?
There is no known exploitation of CVE-2026-45793 in the wild and no public exploit code.
Sources
Also known as BIT-composer-2026-45793, DEBIAN-CVE-2026-45793, GHSA-f9f8-rm49-7jv2, MINI-7gw7-j99m-pm2h, MINI-c4v7-jfv8-vx4f, UBUNTU-CVE-2026-45793 and 1 more.