# CVE-2026-45793: Composer: Github Actions issued GITHUB_TOKEN disclosure in GitHub Actions logs

> Composer may leak GitHub Actions GITHUB_TOKEN values into CI logs when token validation fails due to regex restrictions.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jul 2026
- **Updated:** 15 Jul 2026
- **Also known as:** BIT-composer-2026-45793, DEBIAN-CVE-2026-45793, GHSA-f9f8-rm49-7jv2, MINI-7gw7-j99m-pm2h, MINI-c4v7-jfv8-vx4f, UBUNTU-CVE-2026-45793, openSUSE-SU-2026:11300-1

## What is CVE-2026-45793?

CVE-2026-45793 is a high-severity vulnerability in composer, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Composer is a dependency Manager for the PHP language. Prior to 1.10.28, 2.2.28, and 2.9.8, Composer\IO\BaseIO::loadConfiguration() validates GitHub OAuth tokens with the regex ^[.A-Za-z0-9_]+$ and interpolates rejected tokens into an UnexpectedValueException; GitHub Actions GITHUB_TOKEN values using the ghs_<id>_<base64url-JWT> format can contain -, fail validation, and be disclosed to stderr or CI logs. This issue is fixed in versions 1.10.28, 2.2.28, and 2.9.8.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-45793?

7 open source packages ship an affected version, including composer/composer and composer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `composer/composer` | Packagist | From 1.0 | 1.10.28 |
| `composer/composer` | Packagist | From 1.0 | 1.10.28 |
| `composer/composer` | Packagist | From 2.0.0 | 2.2.28 |
| `composer/composer` | Packagist | From 2.0.0 | 2.2.28 |
| `composer/composer` | Packagist | From 2.3.0 | 2.9.8 |
| `composer/composer` | Packagist | From 2.3.0 | 2.9.8 |
| `composer` | Bitnami | From 1.0.0 | 1.10.28, 2.2.28, 2.9.8 |
| `php-composer2` | openSUSE:Tumbleweed | All versions | 2.10.2-2.1 |

## How do I fix CVE-2026-45793?

Upgrade composer/composer to a fixed version for your release line: 1.10.28, 2.2.28 or 2.9.8.

## Is CVE-2026-45793 being exploited?

There is no known exploitation of CVE-2026-45793 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45793 and fix it if it is affected.

What it is: CVE-2026-45793 is a high-severity vulnerability in composer, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-45793 in the wild and no public exploit code.

Affected packages and fixed versions:
- composer/composer (Packagist): affected from 1.0; fixed in 1.10.28
- composer/composer (Packagist): affected from 1.0; fixed in 1.10.28
- composer/composer (Packagist): affected from 2.0.0; fixed in 2.2.28
- composer/composer (Packagist): affected from 2.0.0; fixed in 2.2.28
- composer/composer (Packagist): affected from 2.3.0; fixed in 2.9.8
- composer/composer (Packagist): affected from 2.3.0; fixed in 2.9.8
- composer (Bitnami): affected from 1.0.0; fixed in 1.10.28, 2.2.28, 2.9.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45793/ (Markdown: https://insights.sbomify.com/CVE-2026-45793/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45793
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45793
- OSV: https://osv.dev/vulnerability/CVE-2026-45793

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45793/
Summaries are generated and may contain mistakes; the official description above is the record.
