{"answers":{"affected":"2 open source packages ship an affected version, including org.openidentityplatform.openam:openam-push-notification.","exploited":"There is no known exploitation of CVE-2026-45794 in the wild and no public exploit code.","fix":"Upgrade org.openidentityplatform.openam:openam-push-notification to 16.1.1 or later.","what":"CVE-2026-45794 is a high-severity unsafe deserialization vulnerability in OpenIdentityPlatform OpenAM, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-45794 and fix it if it is affected.\n\nWhat it is: CVE-2026-45794 is a high-severity unsafe deserialization vulnerability in OpenIdentityPlatform OpenAM, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-45794 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.openidentityplatform.openam:openam-push-notification (Maven): affected all versions; fixed in 16.1.1\n- org.openidentityplatform.openam:openam-push-notification (Maven): affected all versions; fixed in 16.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-45794/ (Markdown: https://insights.sbomify.com/CVE-2026-45794/index.md)","id":"CVE-2026-45794","markdown":"https://insights.sbomify.com/CVE-2026-45794/index.md","name":"CVE-2026-45794","record":{"aliases":["GHSA-pp89-732f-3g8q","UBUNTU-CVE-2026-45794"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenAM access management","requires_auth":"low_privilege","summary":"A low-privileged user can trigger unsafe Java deserialization in OpenAM's SNS callback, potentially leading to code execution or denial of service.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Open Access Management (OpenAM) is an access management solution. Prior to 16.1.1, the anonymous Push Notification SNS callback handled by SnsMessageResource falls back to a CTS predicate blob after a messageId expires from the in-memory dispatcher, treats top-level blob keys as Java class names for Class.forName, and deserializes attacker-controlled JSON through Jackson. A low-privileged user who starts Push Registration and obtains the messageId, shared secret, and challenge can wait for expiry, replace the persistent blob through anonymous callbacks, and trigger class loading and construction in the OpenAM JVM. The primitive can cause classpath-dependent process execution, file writes, or denial of service, although command execution was not confirmed on the tested stock classpath. This issue is fixed in version 16.1.1.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenAM Unsafe Java Deserialization via SNS","id":"CVE-2026-45794","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"deserialization","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Janssen Project: JWE Request Object Signature Verification Bypass in jans-auth-server","id":"CVE-2026-45795"},"packages":[{"ecosystem":"Maven","fixed":["16.1.1"],"introduced":["0"],"last_affected":[],"package":"org.openidentityplatform.openam:openam-push-notification","purl":null,"source":"GHSA-pp89-732f-3g8q"},{"ecosystem":"Maven","fixed":["16.1.1"],"introduced":["0"],"last_affected":[],"package":"org.openidentityplatform.openam:openam-push-notification","purl":"pkg:maven/org.openidentityplatform.openam/openam-push-notification","source":"GHSA-pp89-732f-3g8q"}],"prev":{"headline":"Composer: Github Actions issued GITHUB_TOKEN disclosure in GitHub Actions logs","id":"CVE-2026-45793"},"products":["OpenAM"],"published":"2026-09-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-16","vendors":["OpenIdentityPlatform"]},"summary":"A low-privileged user can trigger unsafe Java deserialization in OpenAM's SNS callback, potentially leading to code execution or denial of service.","url":"https://insights.sbomify.com/CVE-2026-45794/"}