# CVE-2026-45794: OpenAM Unsafe Java Deserialization via SNS

> A low-privileged user can trigger unsafe Java deserialization in OpenAM's SNS callback, potentially leading to code execution or denial of service.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** GHSA-pp89-732f-3g8q, UBUNTU-CVE-2026-45794

## What is CVE-2026-45794?

CVE-2026-45794 is a high-severity unsafe deserialization vulnerability in OpenIdentityPlatform OpenAM, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Open Access Management (OpenAM) is an access management solution. Prior to 16.1.1, the anonymous Push Notification SNS callback handled by SnsMessageResource falls back to a CTS predicate blob after a messageId expires from the in-memory dispatcher, treats top-level blob keys as Java class names for Class.forName, and deserializes attacker-controlled JSON through Jackson. A low-privileged user who starts Push Registration and obtains the messageId, shared secret, and challenge can wait for expiry, replace the persistent blob through anonymous callbacks, and trigger class loading and construction in the OpenAM JVM. The primitive can cause classpath-dependent process execution, file writes, or denial of service, although command execution was not confirmed on the tested stock classpath. This issue is fixed in version 16.1.1.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-45794?

2 open source packages ship an affected version, including org.openidentityplatform.openam:openam-push-notification.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.openidentityplatform.openam:openam-push-notification` | Maven | All versions | 16.1.1 |
| `org.openidentityplatform.openam:openam-push-notification` | Maven | All versions | 16.1.1 |

## How do I fix CVE-2026-45794?

Upgrade org.openidentityplatform.openam:openam-push-notification to 16.1.1 or later.

## Is CVE-2026-45794 being exploited?

There is no known exploitation of CVE-2026-45794 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45794 and fix it if it is affected.

What it is: CVE-2026-45794 is a high-severity unsafe deserialization vulnerability in OpenIdentityPlatform OpenAM, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-45794 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.openidentityplatform.openam:openam-push-notification (Maven): affected all versions; fixed in 16.1.1
- org.openidentityplatform.openam:openam-push-notification (Maven): affected all versions; fixed in 16.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45794/ (Markdown: https://insights.sbomify.com/CVE-2026-45794/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45794
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45794
- OSV: https://osv.dev/vulnerability/CVE-2026-45794

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45794/
Summaries are generated and may contain mistakes; the official description above is the record.
