# CVE-2026-45799: Wire: skipGroup() missing negative-length check allows 10-byte payload to crash any Wire-decoding service

> Attackers can crash Wire-decoding services by sending crafted protobuf payloads that trigger an unhandled exception due to missing negative-length validation.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jul 2026
- **Updated:** 20 Jul 2026
- **Also known as:** ECHO-732c-42e9-bce2, GHSA-7xpr-hc2w-34m9, UBUNTU-CVE-2026-45799

## What is CVE-2026-45799?

CVE-2026-45799 is a high-severity denial of service vulnerability in square wire, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Wire provides gRPC and protocol buffers for Android, Kotlin, Swift, and Java. Prior to 6.3.0 and 7.0.0-alpha03, ByteArrayProtoReader32.skipGroup() and ProtoReader.skipGroup() in wire-runtime do not validate that a LENGTH_DELIMITED field length is non-negative before skip(), allowing a crafted protobuf varint encoding -128 as a signed Int to make skip(-128) move the internal position negative and make the next readByte() throw ArrayIndexOutOfBoundsException instead of the documented IOException or ProtocolException, which can crash services using ProtoAdapter.decode(byte[]) on untrusted payloads. This issue is fixed in versions 6.3.0 and 7.0.0-alpha03.

Weakness: CWE-129 (Improper Validation of Array Index)

## Which versions are affected by CVE-2026-45799?

8 open source packages ship an affected version, including com.squareup.wire:wire-runtime and com.squareup.wire:wire-runtime-jvm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.squareup.wire:wire-runtime` | Maven | All versions | 6.3.0 |
| `com.squareup.wire:wire-runtime` | Maven | All versions | 6.3.0 |
| `com.squareup.wire:wire-runtime` | Maven | From 7.0.0-alpha01 | 7.0.0-alpha03 |
| `com.squareup.wire:wire-runtime` | Maven | From 7.0.0-alpha01 | 7.0.0-alpha03 |
| `com.squareup.wire:wire-runtime-jvm` | Maven | All versions | 6.3.0 |
| `com.squareup.wire:wire-runtime-jvm` | Maven | All versions | 6.3.0 |
| `com.squareup.wire:wire-runtime-jvm` | Maven | From 7.0.0-alpha01 | 7.0.0-alpha03 |
| `com.squareup.wire:wire-runtime-jvm` | Maven | From 7.0.0-alpha01 | 7.0.0-alpha03 |

Products: Squareup Wire.

## How do I fix CVE-2026-45799?

Upgrade com.squareup.wire:wire-runtime to a fixed version for your release line: 6.3.0 or 7.0.0-alpha03.

## Is CVE-2026-45799 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45799 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45799 and fix it if it is affected.

What it is: CVE-2026-45799 is a high-severity denial of service vulnerability in square wire, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45799 exists.

Affected packages and fixed versions:
- com.squareup.wire:wire-runtime (Maven): affected all versions; fixed in 6.3.0
- com.squareup.wire:wire-runtime (Maven): affected all versions; fixed in 6.3.0
- com.squareup.wire:wire-runtime (Maven): affected from 7.0.0-alpha01; fixed in 7.0.0-alpha03
- com.squareup.wire:wire-runtime (Maven): affected from 7.0.0-alpha01; fixed in 7.0.0-alpha03
- com.squareup.wire:wire-runtime-jvm (Maven): affected all versions; fixed in 6.3.0
- com.squareup.wire:wire-runtime-jvm (Maven): affected all versions; fixed in 6.3.0
- com.squareup.wire:wire-runtime-jvm (Maven): affected from 7.0.0-alpha01; fixed in 7.0.0-alpha03
- com.squareup.wire:wire-runtime-jvm (Maven): affected from 7.0.0-alpha01; fixed in 7.0.0-alpha03

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45799/ (Markdown: https://insights.sbomify.com/CVE-2026-45799/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45799
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45799
- OSV: https://osv.dev/vulnerability/CVE-2026-45799

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45799/
Summaries are generated and may contain mistakes; the official description above is the record.
