{"answers":{"affected":"2 open source packages ship an affected version, including setasign/fpdi.","exploited":"There is no known exploitation of CVE-2026-45802 in the wild and no public exploit code.","fix":"Upgrade setasign/fpdi to 2.6.7 or later.","what":"CVE-2026-45802 is a medium-severity denial of service vulnerability in Setasign FPDI, published on 11 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-45802 and fix it if it is affected.\n\nWhat it is: CVE-2026-45802 is a medium-severity denial of service vulnerability in Setasign FPDI, published on 11 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-45802 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- setasign/fpdi (Packagist): affected all versions; fixed in 2.6.7\n- setasign/fpdi (Packagist): affected all versions; fixed in 2.6.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-45802/ (Markdown: https://insights.sbomify.com/CVE-2026-45802/index.md)","id":"CVE-2026-45802","markdown":"https://insights.sbomify.com/CVE-2026-45802/index.md","name":"CVE-2026-45802","record":{"aliases":["GHSA-2mgw-7q6p-8grg"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP PDF library","requires_auth":"low_privilege","summary":"An attacker can cause server crashes and service unavailability by uploading a malicious PDF file to applications using the FPDI library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"FPDI is a collection of PHP classes that facilitate reading pages from existing PDF documents and using them as templates in FPDF. Prior to version 2.6.7, an attacker can upload a small, malicious PDF file that will cause the server-side script to crash due to memory exhaustion or a script time-out. Repeated attacks can lead to sustained service unavailability. This issue has been patched in version 2.6.7.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"FPDI: Memory Exhaustion and Endless Loop in FPDI leads to Denial of Service","id":"CVE-2026-45802","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"gh: GitHub Actions log output in `gh run view` allows terminal escape sequence injection","id":"CVE-2026-45803"},"packages":[{"ecosystem":"Packagist","fixed":["2.6.7"],"introduced":["0"],"last_affected":[],"package":"setasign/fpdi","purl":null,"source":"GHSA-2mgw-7q6p-8grg"},{"ecosystem":"Packagist","fixed":["2.6.7"],"introduced":["0"],"last_affected":[],"package":"setasign/fpdi","purl":"pkg:composer/setasign/fpdi","source":"GHSA-2mgw-7q6p-8grg"}],"prev":{"headline":"GLPI: Unauthorized Debug Mode Activation via Profile Update (Privilege Escalation)","id":"CVE-2026-45801"},"products":["FPDI"],"published":"2026-06-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-12","vendors":["Setasign"]},"summary":"An attacker can cause server crashes and service unavailability by uploading a malicious PDF file to applications using the FPDI library.","url":"https://insights.sbomify.com/CVE-2026-45802/"}