# CVE-2026-45802: FPDI: Memory Exhaustion and Endless Loop in FPDI leads to Denial of Service

> An attacker can cause server crashes and service unavailability by uploading a malicious PDF file to applications using the FPDI library.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jun 2026
- **Updated:** 12 Jun 2026
- **Also known as:** GHSA-2mgw-7q6p-8grg

## What is CVE-2026-45802?

CVE-2026-45802 is a medium-severity denial of service vulnerability in Setasign FPDI, published on 11 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

FPDI is a collection of PHP classes that facilitate reading pages from existing PDF documents and using them as templates in FPDF. Prior to version 2.6.7, an attacker can upload a small, malicious PDF file that will cause the server-side script to crash due to memory exhaustion or a script time-out. Repeated attacks can lead to sustained service unavailability. This issue has been patched in version 2.6.7.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-45802?

2 open source packages ship an affected version, including setasign/fpdi.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `setasign/fpdi` | Packagist | All versions | 2.6.7 |
| `setasign/fpdi` | Packagist | All versions | 2.6.7 |

## How do I fix CVE-2026-45802?

Upgrade setasign/fpdi to 2.6.7 or later.

## Is CVE-2026-45802 being exploited?

There is no known exploitation of CVE-2026-45802 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45802 and fix it if it is affected.

What it is: CVE-2026-45802 is a medium-severity denial of service vulnerability in Setasign FPDI, published on 11 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-45802 in the wild and no public exploit code.

Affected packages and fixed versions:
- setasign/fpdi (Packagist): affected all versions; fixed in 2.6.7
- setasign/fpdi (Packagist): affected all versions; fixed in 2.6.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45802/ (Markdown: https://insights.sbomify.com/CVE-2026-45802/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45802
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45802
- OSV: https://osv.dev/vulnerability/CVE-2026-45802

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45802/
Summaries are generated and may contain mistakes; the official description above is the record.
