# CVE-2026-45803: gh: GitHub Actions log output in `gh run view` allows terminal escape sequence injection

> Attackers can inject terminal escape sequences into GitHub Actions logs, potentially executing arbitrary commands or manipulating the terminal when users view logs.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 May 2026
- **Updated:** 15 May 2026
- **Also known as:** AZL-87048, DEBIAN-CVE-2026-45803, GHSA-crc3-h8v6-qh57, GO-2026-5335, UBUNTU-CVE-2026-45803

## What is CVE-2026-45803?

CVE-2026-45803 is a low-severity command injection vulnerability in cli, published on 15 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

`gh` is GitHub’s official command line tool. From 1.6.0 to before 2.92.0, a security vulnerability has been identified in GitHub CLI that could allow terminal escape sequence injection when users view GitHub Actions workflow logs using gh run view --log or gh run view --log-failed. The vulnerability stems from the way GitHub CLI handles raw Actions log output. The gh run view --log and gh run view --log-failed commands stream workflow log lines to stdout or the configured pager without sanitizing terminal control sequences. An attacker who can influence GitHub Actions log content, for example via a PR triggered workflow, can embed escape sequences that are replayed in the user's terminal when they inspect the run. Depending on the victim's terminal emulator, injected sequences could change the window title, manipulate on screen content, or in some terminal emulators (such as screen) potentially execute arbitrary commands. This vulnerability is fixed in 2.92.0.

Weakness: CWE-150 (Improper Neutralization of Escape, Meta, or Control Sequences)

## Which versions are affected by CVE-2026-45803?

6 open source packages ship an affected version, including github.com/cli/cli and github.com/cli/cli/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cli/cli` | Go | From 1.6.0 | None |
| `github.com/cli/cli` | Go | From 1.6.0 to 1.14.0 | None |
| `github.com/cli/cli` | Go | From 1.6.0 to 1.14.0 | None |
| `github.com/cli/cli/v2` | Go | All versions | 2.92.0 |
| `github.com/cli/cli/v2` | Go | All versions | 2.92.0 |
| `github.com/cli/cli/v2` | Go | All versions | 2.92.0 |

Products: Github Cli.

## How do I fix CVE-2026-45803?

Upgrade to a fixed version.

## Is CVE-2026-45803 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45803 exists.

## Other vulnerabilities in cli

- [CVE-2024-52308](https://insights.sbomify.com/CVE-2024-52308/): Connecting to a malicious Codespaces via GH CLI could allow command execution on the user's computer (high 8.0)
- [CVE-2026-48501](https://insights.sbomify.com/CVE-2026-48501/): GitHub CLI tokens leak via `gh attestation` commands (high 7.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45803 and fix it if it is affected.

What it is: CVE-2026-45803 is a low-severity command injection vulnerability in cli, published on 15 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45803 exists.

Affected packages and fixed versions:
- github.com/cli/cli (Go): affected from 1.6.0; no fix listed
- github.com/cli/cli (Go): affected from 1.6.0 up to 1.14.0; no fix listed
- github.com/cli/cli (Go): affected from 1.6.0 up to 1.14.0; no fix listed
- github.com/cli/cli/v2 (Go): affected all versions; fixed in 2.92.0
- github.com/cli/cli/v2 (Go): affected all versions; fixed in 2.92.0
- github.com/cli/cli/v2 (Go): affected all versions; fixed in 2.92.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45803/ (Markdown: https://insights.sbomify.com/CVE-2026-45803/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45803
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45803
- OSV: https://osv.dev/vulnerability/CVE-2026-45803

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45803/
Summaries are generated and may contain mistakes; the official description above is the record.
