CVE-2026-45805 Penpot: MCP REPL server binds to 0.0.0.0 with unauthenticated /execute endpoint — RCE

High 8.8 Published Updated

An unauthenticated network attacker can execute arbitrary JavaScript on the Penpot MCP REPL server due to insecure binding and lack of authentication.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2026-45805?

CVE-2026-45805 is a high-severity code injection vulnerability in penpot, published on 15 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Penpot is an open-source design tool for design and code collaboration. Prior to 2.15.0, Penpot MCP's mcp/packages/server/src/ReplServer.ts bound the ReplServer to 0.0.0.0:4403 and exposed an unauthenticated /execute endpoint that passed the code field to PluginBridge.executePluginTask(), allowing anyone on the network to execute JavaScript on the server. This issue is fixed in version 2.15.0.

Weakness: CWE-749

Which versions are affected by CVE-2026-45805?

2 open source packages ship an affected version, including @penpot/mcp.

PackageAffectedFixed in
@penpot/mcp npmAll versions2.15.0
@penpot/mcp npmAll versions2.15.0

How do I fix CVE-2026-45805?

Upgrade @penpot/mcp to 2.15.0 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-45805 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45805 exists.

Public exploit code: 1 proofs of concept on GitHub.

Sources

Also known as GHSA-22qr-rp27-j9wm.

Is CVE-2026-45805 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free