{"answers":{"affected":"2 open source packages ship an affected version, including @penpot/mcp.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45805 exists.","fix":"Upgrade @penpot/mcp to 2.15.0 or later.","what":"CVE-2026-45805 is a high-severity code injection vulnerability in penpot, published on 15 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-45805 and fix it if it is affected.\n\nWhat it is: CVE-2026-45805 is a high-severity code injection vulnerability in penpot, published on 15 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45805 exists.\n\nAffected packages and fixed versions:\n- @penpot/mcp (npm): affected all versions; fixed in 2.15.0\n- @penpot/mcp (npm): affected all versions; fixed in 2.15.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-45805/ (Markdown: https://insights.sbomify.com/CVE-2026-45805/index.md)","id":"CVE-2026-45805","markdown":"https://insights.sbomify.com/CVE-2026-45805/index.md","name":"CVE-2026-45805","record":{"aliases":["GHSA-22qr-rp27-j9wm"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Penpot design tool","requires_auth":"none","summary":"An unauthenticated network attacker can execute arbitrary JavaScript on the Penpot MCP REPL server due to insecure binding and lack of authentication.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-749","name":"Exposed Dangerous Method or Function"}],"description":"Penpot is an open-source design tool for design and code collaboration. Prior to 2.15.0, Penpot MCP's mcp/packages/server/src/ReplServer.ts bound the ReplServer to 0.0.0.0:4403 and exposed an unauthenticated /execute endpoint that passed the code field to PluginBridge.executePluginTask(), allowing anyone on the network to execute JavaScript on the server. This issue is fixed in version 2.15.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":"2026-07-25","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-07-25T17:27:14Z","kind":"github_poc","ref":"https://github.com/overgrowncarrot1/PenPot-RCE","stars":0,"title":"Penpot \u003c2.15.0 allows for unathenticated RCE CVE-2026-45805"}],"tier":"weaponised"},"has_fix":true,"headline":"Penpot: MCP REPL server binds to 0.0.0.0 with unauthenticated /execute endpoint — RCE","id":"CVE-2026-45805","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"Penpot: Authenticated SSRF in remote image import via create-file-media-object-from-url","id":"CVE-2026-45806"},"packages":[{"ecosystem":"npm","fixed":["2.15.0"],"introduced":["0"],"last_affected":[],"package":"@penpot/mcp","purl":null,"source":"GHSA-22qr-rp27-j9wm"},{"ecosystem":"npm","fixed":["2.15.0"],"introduced":["0"],"last_affected":[],"package":"@penpot/mcp","purl":"pkg:npm/%40penpot/mcp","source":"GHSA-22qr-rp27-j9wm"}],"prev":{"headline":"Diffusers: TOCTOU Trust Remote Code Bypass","id":"CVE-2026-45804"},"products":["penpot"],"published":"2026-07-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-15","vendors":["penpot"]},"summary":"An unauthenticated network attacker can execute arbitrary JavaScript on the Penpot MCP REPL server due to insecure binding and lack of authentication.","url":"https://insights.sbomify.com/CVE-2026-45805/"}