# CVE-2026-45805: Penpot: MCP REPL server binds to 0.0.0.0 with unauthenticated /execute endpoint — RCE

> An unauthenticated network attacker can execute arbitrary JavaScript on the Penpot MCP REPL server due to insecure binding and lack of authentication.

- **Severity:** High 8.8 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jul 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-22qr-rp27-j9wm

## What is CVE-2026-45805?

CVE-2026-45805 is a high-severity code injection vulnerability in penpot, published on 15 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Penpot is an open-source design tool for design and code collaboration. Prior to 2.15.0, Penpot MCP's mcp/packages/server/src/ReplServer.ts bound the ReplServer to 0.0.0.0:4403 and exposed an unauthenticated /execute endpoint that passed the code field to PluginBridge.executePluginTask(), allowing anyone on the network to execute JavaScript on the server. This issue is fixed in version 2.15.0.

Weakness: CWE-749 (Exposed Dangerous Method or Function)

## Which versions are affected by CVE-2026-45805?

2 open source packages ship an affected version, including @penpot/mcp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@penpot/mcp` | npm | All versions | 2.15.0 |
| `@penpot/mcp` | npm | All versions | 2.15.0 |

## How do I fix CVE-2026-45805?

Upgrade @penpot/mcp to 2.15.0 or later.

## Is CVE-2026-45805 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45805 exists.

Public exploit code:

- Penpot <2.15.0 allows for unathenticated RCE CVE-2026-45805 (github_poc): https://github.com/overgrowncarrot1/PenPot-RCE

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45805 and fix it if it is affected.

What it is: CVE-2026-45805 is a high-severity code injection vulnerability in penpot, published on 15 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45805 exists.

Affected packages and fixed versions:
- @penpot/mcp (npm): affected all versions; fixed in 2.15.0
- @penpot/mcp (npm): affected all versions; fixed in 2.15.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45805/ (Markdown: https://insights.sbomify.com/CVE-2026-45805/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45805
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45805
- OSV: https://osv.dev/vulnerability/CVE-2026-45805

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45805/
Summaries are generated and may contain mistakes; the official description above is the record.
