# CVE-2026-45808: OpenBao's cross-namespace lease revocation via legacy sys/revoke path bypasses ACL

> Attackers can revoke or renew other tenants' credentials via legacy endpoints, bypassing namespace ACLs in OpenBao.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Aug 2026
- **Updated:** 13 Aug 2026
- **Also known as:** BIT-openbao-2026-45808, CLEANSTART-2026-OD55795, GHSA-v8v8-cm84-m686, GO-2026-5657

## What is CVE-2026-45808?

CVE-2026-45808 is a high-severity missing authorization vulnerability in openbao, published on 7 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenBao is an open source identity-based secrets management system. Prior to version 2.5.4, OpenBao's namespaces provide multi-tenant separation. A tenant who intentionally leaks lease identifiers can have their lease and underlying credential revoked or renewed by a user in another tenant via the legacy, undocumented `sys/revoke` and `sys/renew` endpoints. This is fixed in OpenBao v2.5.4.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-45808?

4 open source packages ship an affected version, including github.com/openbao/openbao and openbao.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openbao/openbao` | Go | All versions | None |
| `github.com/openbao/openbao` | Go | All versions | 2.5.4 |
| `github.com/openbao/openbao` | Go | All versions | 2.5.4 |
| `openbao` | Bitnami | All versions | 2.5.4 |

## How do I fix CVE-2026-45808?

Upgrade github.com/openbao/openbao to 2.5.4 or later.

## Is CVE-2026-45808 being exploited?

There is no known exploitation of CVE-2026-45808 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45808 and fix it if it is affected.

What it is: CVE-2026-45808 is a high-severity missing authorization vulnerability in openbao, published on 7 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-45808 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openbao/openbao (Go): affected all versions; no fix listed
- github.com/openbao/openbao (Go): affected all versions; fixed in 2.5.4
- github.com/openbao/openbao (Go): affected all versions; fixed in 2.5.4
- openbao (Bitnami): affected all versions; fixed in 2.5.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45808/ (Markdown: https://insights.sbomify.com/CVE-2026-45808/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45808
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45808
- OSV: https://osv.dev/vulnerability/CVE-2026-45808

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45808/
Summaries are generated and may contain mistakes; the official description above is the record.
