# CVE-2026-45809: OpenSIPS: Denial of Service in watcherinfo XML generation from oversized watcher URI

> Remote attackers can crash OpenSIPS workers via stack buffer overflow in watcherinfo XML generation when presence modules are enabled.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 4 Aug 2026
- **Updated:** 5 Aug 2026
- **Also known as:** GHSA-gx83-2gh8-7v56, UBUNTU-CVE-2026-45809

## What is CVE-2026-45809?

CVE-2026-45809 is a high-severity memory corruption vulnerability in opensips, published on 4 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Versions prior to 3.6.6 and 4.0.0-rc1 contain a denial of service vulnerability in the watcherinfo generation functionality. An attacker can create an oversized watcher entry by sending a SUBSCRIBE Event: presence request with a long From URI, and then trigger presence.winfo watcherinfo XML generation for the same presentity. OpenSIPS copies the stored watcher URI into a fixed-size stack buffer, overflowing it and crashing the process. A remote attacker can crash an OpenSIPS worker in deployments that expose handle_subscribe() and allow watcherinfo (presence.winfo) generation. The issue is configuration-dependent because the presence and presence_xml modules must be loaded and SUBSCRIBE routing must be reachable. This issue has been fixed in versions 3.6.6 and 4.0.0-rc1.

Weakness: CWE-121 (Stack-based Buffer Overflow)

## Which versions are affected by CVE-2026-45809?


## How do I fix CVE-2026-45809?

No fix has been published for CVE-2026-45809 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-45809 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45809 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45809 and fix it if it is affected.

What it is: CVE-2026-45809 is a high-severity memory corruption vulnerability in opensips, published on 4 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-45809 exists.

Affected product: opensips. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45809/ (Markdown: https://insights.sbomify.com/CVE-2026-45809/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45809
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45809
- OSV: https://osv.dev/vulnerability/CVE-2026-45809

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45809/
Summaries are generated and may contain mistakes; the official description above is the record.
