# CVE-2026-45810: Nextcloud: Propfind requests for file comments allowed to load comments for other files

> Authenticated users can read comments for files they do not have access to due to a missing relation check in Propfind requests.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Jun 2026
- **Updated:** 2 Jun 2026
- **Also known as:** BIT-nextcloud-2026-45810, GHSA-285v-p9x9-cjhj

## What is CVE-2026-45810?

CVE-2026-45810 is a medium-severity missing authorization vulnerability in Nextcloud Nextcloud Server, published on 1 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Nextcloud is an open source content collaboration platform. In Nextcloud Server from versions 31.0.0 to before 31.0.12, and 32.0.0 to before 32.0.3, a missing check of a relation allowed authenticated users with access to any file comment, to read the content of all comments. It is recommended that the Nextcloud Server is upgraded to 31.0.12 or 32.0.3. It is recommended that the Nextcloud Enterprise Server is upgraded to 21.0.9.20, 22.2.10.35, 23.0.12.31, 24.0.12.30, 25.0.13.25, 26.0.13.22, 27.1.11.22, 28.0.14.13, 29.0.16.10, 30.0.17.5, 31.0.12 or 32.0.3

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-45810?

1 open source package ship an affected version, including nextcloud. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nextcloud` | Bitnami | From 31.0.0 | 31.0.12, 32.0.3 |

Products: Nextcloud Nextcloud Server.

## How do I fix CVE-2026-45810?

Upgrade nextcloud to a fixed version for your release line: 31.0.12 or 32.0.3.

## Is CVE-2026-45810 being exploited?

There is no known exploitation of CVE-2026-45810 in the wild and no public exploit code.

## Other vulnerabilities in Nextcloud Nextcloud Server

- [CVE-2021-32802](https://insights.sbomify.com/CVE-2021-32802/): Preview generation used third-party library not suited for user-generated content in Nextcloud server (critical 9.3)
- [CVE-2023-26482](https://insights.sbomify.com/CVE-2023-26482/): Scope of workflow operations is not validated in nextcloud server (critical 9.1)
- [CVE-2018-3775](https://insights.sbomify.com/CVE-2018-3775/): Auth bypass in Nextcloud Server (high 8.8)
- [CVE-2023-35172](https://insights.sbomify.com/CVE-2023-35172/): Nextcloud Server password reset endpoint is not brute force protected (high 8.7)
- [CVE-2023-32320](https://insights.sbomify.com/CVE-2023-32320/): Nextcloud Server's brute force protection allows someone to send more requests than intended (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45810 and fix it if it is affected.

What it is: CVE-2026-45810 is a medium-severity missing authorization vulnerability in Nextcloud Nextcloud Server, published on 1 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-45810 in the wild and no public exploit code.

Affected packages and fixed versions:
- nextcloud (Bitnami): affected from 31.0.0; fixed in 31.0.12, 32.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45810/ (Markdown: https://insights.sbomify.com/CVE-2026-45810/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45810
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45810
- OSV: https://osv.dev/vulnerability/CVE-2026-45810

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45810/
Summaries are generated and may contain mistakes; the official description above is the record.
