CVE-2026-45811 Apache NimBLE: Buffer overflow in socket HCI transport

High 7.5 Published Updated

A buffer overflow in Apache NimBLE's HCI socket transport allows attackers with local access or compromised controllers to execute code or cause denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-45811?

CVE-2026-45811 is a high-severity memory corruption vulnerability in Apache NimBLE, published on 24 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Buffer Copy without Checking Size of Input ('Classic Buffer Overflow') vulnerability in Apache NimBLE. The HCI socket transport did not check whether a received HCI event would fit the configured event pool before copying it, allowing a buffer overflow. Severity is low: exploitation requires either a misconfigured pool size or a malicious/compromised controller on the other end of the HCI socket link, not over-the-air Bluetooth access.

This issue affects Apache NimBLE: through 1.9.0.

Users are recommended to upgrade to version 1.10.0, which fixes the issue.

Weakness: CWE-120

Which versions are affected by CVE-2026-45811?

It affects 1 product.

Products include Apache Nimble.

How do I fix CVE-2026-45811?

No fix has been published for CVE-2026-45811 yet. Limit exposure of the affected software until one is available.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2026-45811 being exploited?

There is no known exploitation of CVE-2026-45811 in the wild and no public exploit code.

Sources

Also known as GHSA-mc27-476h-fwpg.

Is CVE-2026-45811 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free