{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-45811 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-45811 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-45811 is a high-severity memory corruption vulnerability in Apache NimBLE, published on 24 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-45811 and fix it if it is affected.\n\nWhat it is: CVE-2026-45811 is a high-severity memory corruption vulnerability in Apache NimBLE, published on 24 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-45811 in the wild and no public exploit code.\n\nAffected product: Apache NimBLE. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-45811/ (Markdown: https://insights.sbomify.com/CVE-2026-45811/index.md)","id":"CVE-2026-45811","markdown":"https://insights.sbomify.com/CVE-2026-45811/index.md","name":"CVE-2026-45811","record":{"aliases":["GHSA-mc27-476h-fwpg"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Bluetooth stack library","requires_auth":"none","summary":"A buffer overflow in Apache NimBLE's HCI socket transport allows attackers with local access or compromised controllers to execute code or cause denial of service.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"nimble","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-120","name":"Buffer Copy without Checking Size of Input"}],"description":"Buffer Copy without Checking Size of Input ('Classic Buffer Overflow') vulnerability in Apache NimBLE.\nThe HCI socket transport did not check whether a received HCI event would fit the configured event pool before copying it, allowing a buffer overflow. Severity is low: exploitation requires either a misconfigured pool size or a malicious/compromised controller on the other end of the HCI socket link, not over-the-air Bluetooth access.\n\nThis issue affects Apache NimBLE: through 1.9.0.\n\nUsers are recommended to upgrade to version 1.10.0, which fixes the issue.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Apache NimBLE: Buffer overflow in socket HCI transport","id":"CVE-2026-45811","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2026"},"n_packages":0,"n_references":2,"next":{"headline":"Apache NimBLE: OOB Read via sizeof(pointer) in Legacy Advertising Report Handler","id":"CVE-2026-45812"},"packages":[],"prev":{"headline":"Nextcloud: Propfind requests for file comments allowed to load comments for other files","id":"CVE-2026-45810"},"products":["Apache NimBLE"],"published":"2026-07-24","related":[{"cvss_score":8.8,"headline":"Apache NimBLE: Incorrect data validation in BASS add/modify source operation","id":"CVE-2026-45813","kev_date_added":null,"published":"2026-07-24"},{"cvss_score":8.1,"headline":"Apache Mynewt NimBLE: Incorrect handling of SMP Security Request could lead to undesirable pairing","id":"CVE-2025-62235","kev_date_added":null,"published":"2026-01-10"},{"cvss_score":7.5,"headline":"Apache NimBLE: Remote reachable assertion in ATT Read Multiple Variable Response handler","id":"CVE-2026-45815","kev_date_added":null,"published":"2026-07-24"},{"cvss_score":7.5,"headline":"Apache NimBLE: NULL pointer dereference vulnerability in SMP LTK request","id":"CVE-2026-45816","kev_date_added":null,"published":"2026-07-24"},{"cvss_score":7.5,"headline":"Apache Mynewt NimBLE: Invalid error handling in pause encryption procedure in NimBLE controller","id":"CVE-2025-52435","kev_date_added":null,"published":"2026-01-10"},{"cvss_score":7.5,"headline":"Apache Mynewt NimBLE: NULL Pointer Dereference in NimBLE host HCI layer","id":"CVE-2025-53477","kev_date_added":null,"published":"2026-01-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-24","vendors":["Apache Software Foundation"]},"summary":"A buffer overflow in Apache NimBLE's HCI socket transport allows attackers with local access or compromised controllers to execute code or cause denial of service.","url":"https://insights.sbomify.com/CVE-2026-45811/"}