# CVE-2026-45811: Apache NimBLE: Buffer overflow in socket HCI transport

> A buffer overflow in Apache NimBLE's HCI socket transport allows attackers with local access or compromised controllers to execute code or cause denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 24 Jul 2026
- **Updated:** 24 Jul 2026
- **Also known as:** GHSA-mc27-476h-fwpg

## What is CVE-2026-45811?

CVE-2026-45811 is a high-severity memory corruption vulnerability in Apache NimBLE, published on 24 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Buffer Copy without Checking Size of Input ('Classic Buffer Overflow') vulnerability in Apache NimBLE.
The HCI socket transport did not check whether a received HCI event would fit the configured event pool before copying it, allowing a buffer overflow. Severity is low: exploitation requires either a misconfigured pool size or a malicious/compromised controller on the other end of the HCI socket link, not over-the-air Bluetooth access.

This issue affects Apache NimBLE: through 1.9.0.

Users are recommended to upgrade to version 1.10.0, which fixes the issue.

Weakness: CWE-120 (Buffer Copy without Checking Size of Input)

## Which versions are affected by CVE-2026-45811?

It affects 1 product.


Products: Apache Nimble.

## How do I fix CVE-2026-45811?

No fix has been published for CVE-2026-45811 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-45811 being exploited?

There is no known exploitation of CVE-2026-45811 in the wild and no public exploit code.

## Other vulnerabilities in Apache NimBLE

- [CVE-2026-45813](https://insights.sbomify.com/CVE-2026-45813/): Apache NimBLE: Incorrect data validation in BASS add/modify source operation (high 8.8)
- [CVE-2025-62235](https://insights.sbomify.com/CVE-2025-62235/): Apache Mynewt NimBLE: Incorrect handling of SMP Security Request could lead to undesirable pairing (high 8.1)
- [CVE-2026-45815](https://insights.sbomify.com/CVE-2026-45815/): Apache NimBLE: Remote reachable assertion in ATT Read Multiple Variable Response handler (high 7.5)
- [CVE-2026-45816](https://insights.sbomify.com/CVE-2026-45816/): Apache NimBLE: NULL pointer dereference vulnerability in SMP LTK request (high 7.5)
- [CVE-2025-52435](https://insights.sbomify.com/CVE-2025-52435/): Apache Mynewt NimBLE: Invalid error handling in pause encryption procedure in NimBLE controller (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45811 and fix it if it is affected.

What it is: CVE-2026-45811 is a high-severity memory corruption vulnerability in Apache NimBLE, published on 24 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-45811 in the wild and no public exploit code.

Affected product: Apache NimBLE. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45811/ (Markdown: https://insights.sbomify.com/CVE-2026-45811/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45811
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45811
- OSV: https://osv.dev/vulnerability/CVE-2026-45811

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45811/
Summaries are generated and may contain mistakes; the official description above is the record.
