# CVE-2026-45812: Apache NimBLE: OOB Read via sizeof(pointer) in Legacy Advertising Report Handler

> An out-of-bounds read in Apache NimBLE allows attackers to read memory or cause crashes when using third-party controllers that batch advertising reports.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 24 Jul 2026
- **Updated:** 24 Jul 2026
- **Also known as:** GHSA-m9xh-wpcw-qvx9

## What is CVE-2026-45812?

CVE-2026-45812 is a medium-severity memory corruption vulnerability in Apache NimBLE, published on 24 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Incorrect Calculation of Buffer Size vulnerability in Apache NimBLE when processing Legacy Advertising Report HCI event.

When a single HCI advertising report event bundles multiple reports, NimBLE miscalculated the offset to the next report. This can cause the host to read past the end of the buffer and deliver a GAP event with bogus data to the application.

Severity is low: NimBLE's own controller never batches multiple reports into one event, so this only matters when NimBLE's host is paired with a third-party controller that does.

This issue affects Apache NimBLE: through 1.9.0.

Users are recommended to upgrade to version 1.10.0, which fixes the issue.

Weakness: CWE-131 (Incorrect Calculation of Buffer Size)

## Which versions are affected by CVE-2026-45812?

It affects 1 product.


Products: Apache Nimble.

## How do I fix CVE-2026-45812?

No fix has been published for CVE-2026-45812 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-45812 being exploited?

There is no known exploitation of CVE-2026-45812 in the wild and no public exploit code.

## Other vulnerabilities in Apache NimBLE

- [CVE-2026-45813](https://insights.sbomify.com/CVE-2026-45813/): Apache NimBLE: Incorrect data validation in BASS add/modify source operation (high 8.8)
- [CVE-2025-62235](https://insights.sbomify.com/CVE-2025-62235/): Apache Mynewt NimBLE: Incorrect handling of SMP Security Request could lead to undesirable pairing (high 8.1)
- [CVE-2026-45811](https://insights.sbomify.com/CVE-2026-45811/): Apache NimBLE: Buffer overflow in socket HCI transport (high 7.5)
- [CVE-2026-45815](https://insights.sbomify.com/CVE-2026-45815/): Apache NimBLE: Remote reachable assertion in ATT Read Multiple Variable Response handler (high 7.5)
- [CVE-2026-45816](https://insights.sbomify.com/CVE-2026-45816/): Apache NimBLE: NULL pointer dereference vulnerability in SMP LTK request (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45812 and fix it if it is affected.

What it is: CVE-2026-45812 is a medium-severity memory corruption vulnerability in Apache NimBLE, published on 24 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-45812 in the wild and no public exploit code.

Affected product: Apache NimBLE. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45812/ (Markdown: https://insights.sbomify.com/CVE-2026-45812/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45812
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45812
- OSV: https://osv.dev/vulnerability/CVE-2026-45812

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45812/
Summaries are generated and may contain mistakes; the official description above is the record.
