CVE-2026-45813 Apache NimBLE: Incorrect data validation in BASS add/modify source operation

High 8.8 Published Updated

A nearby attacker with paired access can trigger a stack buffer overflow in Apache NimBLE, potentially leading to code execution or denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-45813?

CVE-2026-45813 is a high-severity memory corruption vulnerability in Apache NimBLE, published on 24 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Out-of-bounds Write, Integer Underflow (Wrap or Wraparound) vulnerability in Apache NimBLE BASS service. Improper validation when parsing BASS service  "Add Source" and "Modify Source" operation PDU could results in stack buffer overflow or arbitrary out-of-bound read.

This can be triggered by nearby devices over Bluetooth connection, however pairing is required prior to accessing BASS service, which depending on device configuration may or may not require user action.

This issue affects Apache NimBLE: through 1.9.0.

Users are recommended to upgrade to version 1.10.0, which fixes the issue.

Weakness: CWE-787, CWE-191

Which versions are affected by CVE-2026-45813?

It affects 1 product.

Products include Apache Nimble.

How do I fix CVE-2026-45813?

No fix has been published for CVE-2026-45813 yet. Limit exposure of the affected software until one is available.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2026-45813 being exploited?

There is no known exploitation of CVE-2026-45813 in the wild and no public exploit code.

Sources

Also known as GHSA-2vqf-9746-8h23.

Is CVE-2026-45813 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free