CVE-2026-45815 Apache NimBLE: Remote reachable assertion in ATT Read Multiple Variable Response handler

High 7.5 Published Updated

A remote attacker can cause a denial of service in Apache NimBLE by sending a crafted Bluetooth response that triggers an assertion failure.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-45815?

CVE-2026-45815 is a high-severity denial of service vulnerability in Apache NimBLE, published on 24 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Reachable Assertion vulnerability in Apache NimBLE. A specially crafted ATT Read Multiple Variable Response (BLE_ATT_OP_READ_MULT_VAR_RSP) may trigger assert in ATT parser.

Severity is medium as this requires DUT to first send ATT Read Multiple Variable Request.

This issue affects Apache NimBLE: through 1.9.0.

Users are recommended to upgrade to version 1.10.0, which fixes the issue.

Weakness: CWE-617

Which versions are affected by CVE-2026-45815?

It affects 1 product.

Products include Apache Nimble.

How do I fix CVE-2026-45815?

No fix has been published for CVE-2026-45815 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-45815 being exploited?

There is no known exploitation of CVE-2026-45815 in the wild and no public exploit code.

Sources

Also known as GHSA-v377-9cxj-ww4r.

Is CVE-2026-45815 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free