CVE-2026-45816 Apache NimBLE: NULL pointer dereference vulnerability in SMP LTK request

High 7.5 Published Updated

A NULL pointer dereference in Apache NimBLE can cause a denial of service when asserts are disabled and a misbehaving controller is present.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-45816?

CVE-2026-45816 is a high-severity vulnerability in Apache NimBLE, published on 24 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

NULL Pointer Dereference vulnerability in Apache NimBLE in LE Long Term Key Request event.

This requires disabled asserts (otherwise assert would trigger before NULL dereference) and bogus (or misbehaving) controller, thus severity is low.

This issue affects Apache NimBLE: through 1.9.0.

Users are recommended to upgrade to version 1.10.0, which fixes the issue.

Weakness: CWE-476

Which versions are affected by CVE-2026-45816?

It affects 1 product.

Products include Apache Nimble.

How do I fix CVE-2026-45816?

No fix has been published for CVE-2026-45816 yet. Limit exposure of the affected software until one is available.

Is CVE-2026-45816 being exploited?

There is no known exploitation of CVE-2026-45816 in the wild and no public exploit code.

Sources

Also known as GHSA-r25p-7q83-xfq4.

Is CVE-2026-45816 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free