# CVE-2026-45820: fflate unzipSync can enter an infinite loop when parsing malformed ZIP64 archives

> Attackers can cause a denial of service in applications using fflate by providing a crafted ZIP archive that triggers an infinite loop during decompression.

- **Severity:** Medium 6.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U/S:N/AU:Y/R:U/V:D/RE:M/U:Amber`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jul 2026
- **Updated:** 22 Jul 2026
- **Also known as:** CLEANSTART-2026-DF16083, CLEANSTART-2026-DW46246, CLSA-2026-1789897715, CLSA-2026-1790161290, ECHO-3bcd-0586-7ae3, GHSA-px8p-9vwx-vf98, MINI-23qh-wmmj-6j6h, MINI-384g-v8wh-9736, MINI-48rf-2g47-4f6w, MINI-8cp9-hqx4-ch29, MINI-8j7x-6j65-cqr7, MINI-c73c-5m2q-3547, MINI-fr49-5hj6-rj78, MINI-hg9v-mh8x-q7rw, MINI-jfv7-j9xg-8gfm, MINI-m8fr-5f5f-3h39, MINI-rj8h-hff6-958w, MINI-x76c-2847-38mw

## What is CVE-2026-45820?

CVE-2026-45820 is a medium-severity denial of service vulnerability in 101arrowz fflate, published on 22 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

fflate through 0.8.2 is vulnerable to denial of service via an infinite loop in unzipSync(). A crafted ZIP archive with a central directory entry declaring compressed_size=0xFFFFFFFF (ZIP64 sentinel) but missing the required ZIP64 extra field tag 0x0001 causes z64e() to loop indefinitely due to out-of-bounds reads returning undefined, which coerces to 0, keeping the loop condition permanently true.

Weakness: CWE-835 (Loop with Unreachable Exit Condition), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-45820?

10 open source packages ship an affected version, including fflate. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fflate` | npm | From 0.4.5 | 0.4.9 |
| `fflate` | npm | From 0.4.5 | 0.4.9 |
| `fflate` | npm | From 0.5.0 | 0.5.4 |
| `fflate` | npm | From 0.5.0 | 0.5.4 |
| `fflate` | npm | From 0.6.0 | 0.6.11 |
| `fflate` | npm | From 0.6.0 | 0.6.11 |
| `fflate` | npm | From 0.7.0 | 0.7.5 |
| `fflate` | npm | From 0.7.0 | 0.7.5 |
| `fflate` | npm | From 0.8.0 | 0.8.3 |
| `fflate` | npm | From 0.8.0 | 0.8.3 |

Products: 101arrowz Fflate.

## How do I fix CVE-2026-45820?

Upgrade fflate to a fixed version for your release line: 0.4.9, 0.5.4, 0.6.11 or 0.7.5.

## Is CVE-2026-45820 being exploited?

There is no known exploitation of CVE-2026-45820 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-45820 and fix it if it is affected.

What it is: CVE-2026-45820 is a medium-severity denial of service vulnerability in 101arrowz fflate, published on 22 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-45820 in the wild and no public exploit code.

Affected packages and fixed versions:
- fflate (npm): affected from 0.4.5; fixed in 0.4.9
- fflate (npm): affected from 0.4.5; fixed in 0.4.9
- fflate (npm): affected from 0.5.0; fixed in 0.5.4
- fflate (npm): affected from 0.5.0; fixed in 0.5.4
- fflate (npm): affected from 0.6.0; fixed in 0.6.11
- fflate (npm): affected from 0.6.0; fixed in 0.6.11
- fflate (npm): affected from 0.7.0; fixed in 0.7.5
- fflate (npm): affected from 0.7.0; fixed in 0.7.5
- fflate (npm): affected from 0.8.0; fixed in 0.8.3
- fflate (npm): affected from 0.8.0; fixed in 0.8.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-45820/ (Markdown: https://insights.sbomify.com/CVE-2026-45820/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-45820
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-45820
- OSV: https://osv.dev/vulnerability/CVE-2026-45820

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-45820/
Summaries are generated and may contain mistakes; the official description above is the record.
