CVE-2026-45822 decode-uri-component: Denial of service via exponential decoding of malformed percent-encoded input
An attacker can cause denial of service via CPU exhaustion and event-loop blocking by sending crafted input to the decode-uri-component library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-45822?
CVE-2026-45822 is a medium-severity denial of service vulnerability in SamVerschueren decode-uri-component, published on 30 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
decode-uri-component through 0.4.1 is vulnerable to denial of service. The decode() function splits input on '%' producing N tokens and calls decodeComponents(), exhibiting super-linear parsing time: 200 '%ab' tokens takes approximately 0.7s, 700 tokens approximately 6s, and 1400 tokens approximately 33s. An attacker can cause significant CPU consumption and event-loop blocking via crafted input.
Which versions are affected by CVE-2026-45822?
2 open source packages ship an affected version, including decode-uri-component.
| Package | Affected | Fixed in |
|---|---|---|
decode-uri-component npm | All versions | 0.5.0 |
decode-uri-component npm | All versions | 0.5.0 |
How do I fix CVE-2026-45822?
Upgrade decode-uri-component to 0.5.0 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-45822 being exploited?
There is no known exploitation of CVE-2026-45822 in the wild and no public exploit code.
Sources
Also known as AZL-92075, CLSA-2026-1788255041, ECHO-d9f5-fce4-21d3, GHSA-vcc3-ghjq-m6fr, MINI-2h9j-78gp-5343, MINI-2mgg-m3w7-8gh6 and 16 more.