{"answers":{"affected":"2 open source packages ship an affected version, including decode-uri-component.","exploited":"There is no known exploitation of CVE-2026-45822 in the wild and no public exploit code.","fix":"Upgrade decode-uri-component to 0.5.0 or later.","what":"CVE-2026-45822 is a medium-severity denial of service vulnerability in SamVerschueren decode-uri-component, published on 30 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-45822 and fix it if it is affected.\n\nWhat it is: CVE-2026-45822 is a medium-severity denial of service vulnerability in SamVerschueren decode-uri-component, published on 30 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-45822 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- decode-uri-component (npm): affected all versions; fixed in 0.5.0\n- decode-uri-component (npm): affected all versions; fixed in 0.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-45822/ (Markdown: https://insights.sbomify.com/CVE-2026-45822/index.md)","id":"CVE-2026-45822","markdown":"https://insights.sbomify.com/CVE-2026-45822/index.md","name":"CVE-2026-45822","record":{"aliases":["AZL-92075","CLSA-2026-1788255041","ECHO-d9f5-fce4-21d3","GHSA-vcc3-ghjq-m6fr","MINI-2h9j-78gp-5343","MINI-2mgg-m3w7-8gh6","MINI-5crg-g382-3xrw","MINI-6646-xf57-9mpx","MINI-7c86-jv8r-86vj","MINI-7j2x-fp37-wmmm","MINI-8558-wjfh-54pw","MINI-8mph-hv7x-8v7m","MINI-g76g-mjcr-fpqq","MINI-hp69-7rvq-vvjq","MINI-hr3h-4585-6pg4","MINI-hvxj-g4h3-hh4w","MINI-j6g6-37mg-82j2","MINI-j6wx-m5xv-g3g2","MINI-jr5h-786x-mh2g","MINI-r9jw-6hc6-2h9v","MINI-v9cq-4vqq-32pc","UBUNTU-CVE-2026-45822"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript URI decoding library","requires_auth":"none","summary":"An attacker can cause denial of service via CPU exhaustion and event-loop blocking by sending crafted input to the decode-uri-component library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"seal","cpe":[],"cvss":{"score":6.6,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U/S:N/AU:Y/R:U/V:D/RE:M/U:Amber","version":"4.0"},"cwes":[{"id":"CWE-407","name":"Inefficient Algorithmic Complexity"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"decode-uri-component through 0.4.1 is vulnerable to denial of service. The decode() function splits input on '%' producing N tokens and calls decodeComponents(), exhibiting super-linear parsing time: 200 '%ab' tokens takes approximately 0.7s, 700 tokens approximately 6s, and 1400 tokens approximately 33s. An attacker can cause significant CPU consumption and event-loop blocking via crafted input.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"decode-uri-component: Denial of service via exponential decoding of malformed percent-encoded input","id":"CVE-2026-45822","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"ChromaDB Python project has a pre-authentication code injection vulnerability","id":"CVE-2026-45829"},"packages":[{"ecosystem":"npm","fixed":["0.5.0"],"introduced":["0"],"last_affected":[],"package":"decode-uri-component","purl":null,"source":"GHSA-vcc3-ghjq-m6fr"},{"ecosystem":"npm","fixed":["0.5.0"],"introduced":["0"],"last_affected":[],"package":"decode-uri-component","purl":"pkg:npm/decode-uri-component","source":"GHSA-vcc3-ghjq-m6fr"}],"prev":{"headline":"fflate unzipSync can enter an infinite loop when parsing malformed ZIP64 archives","id":"CVE-2026-45820"},"products":["decode-uri-component"],"published":"2026-06-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-30","vendors":["SamVerschueren"]},"summary":"An attacker can cause denial of service via CPU exhaustion and event-loop blocking by sending crafted input to the decode-uri-component library.","url":"https://insights.sbomify.com/CVE-2026-45822/"}