CVE-2026-4600 jsrsasign: DSA signatures or X.509 certificates can be forged via DSA domain-parameter validation in KJUR.crypto.DSA.setPublic

Critical 9.1 Published Updated

Attackers can forge DSA signatures and X.509 certificates by exploiting improper domain-parameter validation in the jsrsasign library.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-4600?

CVE-2026-4600 is a critical vulnerability in jsrsasign, published on 23 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Versions of the package jsrsasign before 11.1.1 are vulnerable to Improper Verification of Cryptographic Signature via the DSA domain-parameter validation in KJUR.crypto.DSA.setPublic (and the related DSA/X509 verification flow in src/dsa-2.0.js). An attacker can forge DSA signatures or X.509 certificates that X509.verifySignature() accepts by supplying malicious domain parameters such as g=1, y=1, and a fixed r=1, which make the verification equation true for any hash.

Weakness: CWE-347

Which versions are affected by CVE-2026-4600?

2 open source packages ship an affected version, including jsrsasign. It affects 1 product.

PackageAffectedFixed in
jsrsasign npmAll versions11.1.1
jsrsasign npmAll versions11.1.1

Products include Kjur Jsrsasign.

How do I fix CVE-2026-4600?

Upgrade jsrsasign to 11.1.1 or later.

Is CVE-2026-4600 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-4600 exists.

Sources

Also known as GHSA-wvqx-v3f6-w8rh.

Is CVE-2026-4600 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free