# CVE-2026-4600: jsrsasign: DSA signatures or X.509 certificates can be forged via DSA domain-parameter validation in KJUR.crypto.DSA.setPublic

> Attackers can forge DSA signatures and X.509 certificates by exploiting improper domain-parameter validation in the jsrsasign library.

- **Severity:** Critical 9.1 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Mar 2026
- **Updated:** 10 Sep 2026
- **Also known as:** GHSA-wvqx-v3f6-w8rh

## What is CVE-2026-4600?

CVE-2026-4600 is a critical vulnerability in jsrsasign, published on 23 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of the package jsrsasign before 11.1.1 are vulnerable to Improper Verification of Cryptographic Signature via the DSA domain-parameter validation in KJUR.crypto.DSA.setPublic (and the related DSA/X509 verification flow in src/dsa-2.0.js). An attacker can forge DSA signatures or X.509 certificates that X509.verifySignature() accepts by supplying malicious domain parameters such as g=1, y=1, and a fixed r=1, which make the verification equation true for any hash.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2026-4600?

2 open source packages ship an affected version, including jsrsasign. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jsrsasign` | npm | All versions | 11.1.1 |
| `jsrsasign` | npm | All versions | 11.1.1 |

Products: Kjur Jsrsasign.

## How do I fix CVE-2026-4600?

Upgrade jsrsasign to 11.1.1 or later.

## Is CVE-2026-4600 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-4600 exists.

## Other vulnerabilities in jsrsasign

- [CVE-2020-14967](https://insights.sbomify.com/CVE-2020-14967/): RSA PKCS#1 decryption vulnerability with prepending zeros in jsrsasign (critical 9.8)
- [CVE-2020-14968](https://insights.sbomify.com/CVE-2020-14968/): RSA-PSS signature validation vulnerability by prepending zeros in jsrsasign (critical 9.8)
- [CVE-2026-4601](https://insights.sbomify.com/CVE-2026-4601/): jsrsasign: Missing cryptographic validation during DSA signing enables private key extraction (critical 9.4)
- [CVE-2026-4599](https://insights.sbomify.com/CVE-2026-4599/): jsrsasign: Incomplete Comparison Allows DSA Private Key Recovery via Biased Nonce Generation (critical 9.3)
- [CVE-2021-30246](https://insights.sbomify.com/CVE-2021-30246/): RSA signature validation vulnerability on maleable encoded message in jsrsasign (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-4600 and fix it if it is affected.

What it is: CVE-2026-4600 is a critical vulnerability in jsrsasign, published on 23 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-4600 exists.

Affected packages and fixed versions:
- jsrsasign (npm): affected all versions; fixed in 11.1.1
- jsrsasign (npm): affected all versions; fixed in 11.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-4600/ (Markdown: https://insights.sbomify.com/CVE-2026-4600/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-4600
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-4600
- OSV: https://osv.dev/vulnerability/CVE-2026-4600

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-4600/
Summaries are generated and may contain mistakes; the official description above is the record.
