CVE-2026-4610 ProfileGrid <= 5.9.9.2 - Authenticated (Subscriber+) Stored Cross-Site Scripting via Message Content

Medium 6.4 Published Updated

Authenticated attackers can inject arbitrary scripts via message content, leading to script execution in victim browsers.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-4610?

CVE-2026-4610 is a medium-severity cross-site scripting vulnerability in metagauss ProfileGrid – User Profiles, Groups and Communities, published on 23 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

The ProfileGrid – User Profiles, Groups and Communities plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'pm_author_message' parameter in the pm_send_message_to_author function in all versions up to, and including, 5.9.9.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 5.9.8.5.

Weakness: CWE-79

Which versions are affected by CVE-2026-4610?

How do I fix CVE-2026-4610?

No fix has been published for CVE-2026-4610 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-4610 being exploited?

There is no known exploitation of CVE-2026-4610 in the wild and no public exploit code.

Sources

Also known as GHSA-377q-j2cj-r6x8.

Is CVE-2026-4610 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free