CVE-2026-46334 OpenSIPS: Denial of Service in SDP bandwidth parsing via QoS SDP cloning

High 8.7 Published Updated

An unauthenticated remote attacker can crash the OpenSIPS server by sending a malformed SDP bandwidth line that triggers a null dereference during cloning.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-46334?

CVE-2026-46334 is a high-severity vulnerability in opensips, published on 4 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Versions prior to 3.6.6 and 4.0.0-rc1 contain a denial of service vulnerability in the SDP bandwidth-line parsing logic. A SIP request with Content-Type: application/sdp and a malformed session-level SDP bandwidth line missing the required colon delimiter can corrupt parsed SDP bandwidth metadata. When a route or module subsequently clones the corrupted SDP state, as occurs with dialog and QoS processing, the OpenSIPS worker process crashes. An unauthenticated remote attacker can therefore trigger a crash in any configuration whose routing script parses attacker-controlled SDP and applies dialog/QoS processing. This issue has been fixed in versions 3.6.6 and 4.0.0-rc1.

Weakness: CWE-476, CWE-20

Which versions are affected by CVE-2026-46334?

How do I fix CVE-2026-46334?

No fix has been published for CVE-2026-46334 yet. Limit exposure of the affected software until one is available.

Is CVE-2026-46334 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46334 exists.

Sources

Also known as GHSA-rh36-mhpv-cx2r, UBUNTU-CVE-2026-46334.

Is CVE-2026-46334 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free