{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46334 exists.","fix":"No fix has been published for CVE-2026-46334 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-46334 is a high-severity vulnerability in opensips, published on 4 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-46334 and fix it if it is affected.\n\nWhat it is: CVE-2026-46334 is a high-severity vulnerability in opensips, published on 4 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46334 exists.\n\nAffected product: opensips. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-46334/ (Markdown: https://insights.sbomify.com/CVE-2026-46334/index.md)","id":"CVE-2026-46334","markdown":"https://insights.sbomify.com/CVE-2026-46334/index.md","name":"CVE-2026-46334","record":{"aliases":["GHSA-rh36-mhpv-cx2r","UBUNTU-CVE-2026-46334"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"SIP server","requires_auth":"none","summary":"An unauthenticated remote attacker can crash the OpenSIPS server by sending a malformed SDP bandwidth line that triggers a null dereference during cloning.","user_interaction":"not_required","vuln_class":"null_dereference"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-476","name":"NULL Pointer Dereference"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Versions prior to 3.6.6 and 4.0.0-rc1 contain a denial of service vulnerability in the SDP bandwidth-line parsing logic. A SIP request with Content-Type: application/sdp and a malformed session-level SDP bandwidth line missing the required colon delimiter can corrupt parsed SDP bandwidth metadata. When a route or module subsequently clones the corrupted SDP state, as occurs with dialog and QoS processing, the OpenSIPS worker process crashes. An unauthenticated remote attacker can therefore trigger a crash in any configuration whose routing script parses attacker-controlled SDP and applies dialog/QoS processing. This issue has been fixed in versions 3.6.6 and 4.0.0-rc1.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"OpenSIPS: Denial of Service in SDP bandwidth parsing via QoS SDP cloning","id":"CVE-2026-46334","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"null_dereference","year":"2026"},"n_packages":0,"n_references":3,"next":{"headline":"Manyfold: Authenticated Path Traversal via File Rename","id":"CVE-2026-46336"},"packages":[],"prev":{"headline":"ptrace: slightly saner 'get_dumpable()' logic","id":"CVE-2026-46333"},"products":["opensips"],"published":"2026-08-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-05","vendors":["OpenSIPS"]},"summary":"An unauthenticated remote attacker can crash the OpenSIPS server by sending a malformed SDP bandwidth line that triggers a null dereference during cloning.","url":"https://insights.sbomify.com/CVE-2026-46334/"}