# CVE-2026-4634: Keycloak: keycloak: denial of service via excessive processing of openid connect scope parameters

> An unauthenticated attacker can cause a Denial of Service on Keycloak by sending a specially crafted POST request with an excessively long scope parameter.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Apr 2026
- **Updated:** 6 Oct 2026
- **Also known as:** BIT-keycloak-2026-4634, ECHO-5745-1868-1f70, GHSA-h4wv-g838-66g3, MINI-p6f6-m593-g9m8, MINI-r7hv-4mc7-v5jm

## What is CVE-2026-4634?

CVE-2026-4634 is a high-severity denial of service vulnerability in Redhat Build of Keycloak, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw was found in Keycloak. An unauthenticated attacker can exploit this vulnerability by sending a specially crafted POST request with an excessively long scope parameter to the OpenID Connect (OIDC) token endpoint. This leads to high resource consumption and prolonged processing times, ultimately resulting in a Denial of Service (DoS) for the Keycloak server.

Weakness: CWE-1050 (Excessive Platform Resource Consumption within a Loop)

## Which versions are affected by CVE-2026-4634?

3 open source packages ship an affected version, including org.keycloak:keycloak-services and keycloak. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-services` | Maven | All versions | 26.5.7 |
| `org.keycloak:keycloak-services` | Maven | All versions | 26.5.7 |
| `keycloak` | Bitnami | From 26.2.0 | 26.2.1, 26.3.0, 26.4.1, 26.5.0 |

Products: Redhat Build of Keycloak.

## How do I fix CVE-2026-4634?

Upgrade org.keycloak:keycloak-services to 26.5.7 or later.

## Is CVE-2026-4634 being exploited?

There is no known exploitation of CVE-2026-4634 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Build of Keycloak

- [CVE-2026-15572](https://insights.sbomify.com/CVE-2026-15572/): Keycloak-services: keycloak-services: dcr protocol mapper type-swap policy bypass allows privilege escalation (high 8.8)
- [CVE-2026-3047](https://insights.sbomify.com/CVE-2026-3047/): Keycloak SAML Broken has Authentication Bypass by Primary Weakness (high 8.8)
- [CVE-2026-15573](https://insights.sbomify.com/CVE-2026-15573/): Keycloak-services: keycloak-services: authorization bypass via unnormalized uri matching in pathmatcher (high 8.1)
- [CVE-2026-16102](https://insights.sbomify.com/CVE-2026-16102/): Keycloak-services: keycloak-services: default dcr policy allows role forgery via user property mappers (high 8.1)
- [CVE-2026-1609](https://insights.sbomify.com/CVE-2026-1609/): Org.keycloak/keycloak-quarkus-server: keycloak: unauthorized access via jwt authorization grant with disabled users (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-4634 and fix it if it is affected.

What it is: CVE-2026-4634 is a high-severity denial of service vulnerability in Redhat Build of Keycloak, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-4634 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 26.5.7
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 26.5.7
- keycloak (Bitnami): affected from 26.2.0; fixed in 26.2.1, 26.3.0, 26.4.1, 26.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-4634/ (Markdown: https://insights.sbomify.com/CVE-2026-4634/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-4634
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-4634
- OSV: https://osv.dev/vulnerability/CVE-2026-4634

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-4634/
Summaries are generated and may contain mistakes; the official description above is the record.
