# CVE-2026-46341: Apify MCP server: Domain Allowlist Bypass in fetch-apify-docs via String Prefix Matching

> Attackers can bypass domain allowlists in the Apify MCP server to fetch arbitrary content, potentially exposing sensitive data to AI agents.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Jul 2026
- **Updated:** 17 Jul 2026
- **Also known as:** GHSA-jwp7-wg77-3w9v

## What is CVE-2026-46341?

CVE-2026-46341 is a medium-severity server-side request forgery vulnerability in apify-mcp-server, published on 16 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The Apify MCP server enables AI agents to extract data from websites using ready-made scrapers, crawlers, and automation tools available on the Apify Store. Prior to 0.9.21, the fetch-apify-docs tool in src/tools/common/fetch_apify_docs.ts validates allowlisted documentation domains with String.startsWith() rather than URL hostname comparison, allowing attacker-controlled URLs such as `https://docs.apify.com.evil.com/` and `https://docs.apify.com@evil.com/` to pass the ALLOWED_DOC_DOMAINS check and return arbitrary fetched content to the LLM. This issue is fixed in version 0.9.21.

Weakness: CWE-20 (Improper Input Validation), CWE-183 (Permissive List of Allowed Inputs)

## Which versions are affected by CVE-2026-46341?

2 open source packages ship an affected version, including @apify/actors-mcp-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@apify/actors-mcp-server` | npm | All versions | 0.9.21 |
| `@apify/actors-mcp-server` | npm | All versions | 0.9.21 |

## How do I fix CVE-2026-46341?

Upgrade @apify/actors-mcp-server to 0.9.21 or later.

## Is CVE-2026-46341 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46341 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46341 and fix it if it is affected.

What it is: CVE-2026-46341 is a medium-severity server-side request forgery vulnerability in apify-mcp-server, published on 16 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46341 exists.

Affected packages and fixed versions:
- @apify/actors-mcp-server (npm): affected all versions; fixed in 0.9.21
- @apify/actors-mcp-server (npm): affected all versions; fixed in 0.9.21

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46341/ (Markdown: https://insights.sbomify.com/CVE-2026-46341/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46341
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46341
- OSV: https://osv.dev/vulnerability/CVE-2026-46341

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46341/
Summaries are generated and may contain mistakes; the official description above is the record.
