# CVE-2026-46353: BigBlueButton API checksum bypass via presentationUploadExternalUrl

> Attackers can bypass API checksum validation in BigBlueButton to send valid requests to certain endpoints without proper authentication signatures.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 16 Jul 2026
- **Updated:** 16 Jul 2026
- **Also known as:** GHSA-43hc-5g2m-cqff

## What is CVE-2026-46353?

CVE-2026-46353 is a high-severity vulnerability in bigbluebutton, published on 16 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

BigBlueButton is an open-source virtual classroom. Prior to 3.0.21, bbb-web checksum validation could be bypassed when a presentationUploadExternalUrl parameter was supplied to API request handling in CreateMeeting.java and ValidationService.java, allowing a user to send valid requests to some endpoints without a checksum. This issue is fixed in version 3.0.21.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-46353?


## How do I fix CVE-2026-46353?

No fix has been published for CVE-2026-46353 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-46353 being exploited?

There is no known exploitation of CVE-2026-46353 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46353 and fix it if it is affected.

What it is: CVE-2026-46353 is a high-severity vulnerability in bigbluebutton, published on 16 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-46353 in the wild and no public exploit code.

Affected product: bigbluebutton. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46353/ (Markdown: https://insights.sbomify.com/CVE-2026-46353/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46353
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46353
- OSV: https://osv.dev/vulnerability/CVE-2026-46353

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46353/
Summaries are generated and may contain mistakes; the official description above is the record.
