# CVE-2026-46354: Coder: PKCS#7 signature bypass in Azure instance identity allows unauthenticated agent token theft

> Attackers can steal agent session tokens by forging PKCS#7 signatures in Azure instance identity validation, bypassing authentication to access victim workspaces.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jul 2026
- **Updated:** 8 Jul 2026
- **Also known as:** GHSA-6x44-w3xg-hqqf, GO-2026-5196

## What is CVE-2026-46354?

CVE-2026-46354 is a critical authentication bypass vulnerability in coder, published on 7 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Coder allows organizations to provision remote development environments via Terraform. In versions prior tp 2.24.5, 2.29.13, 2.30.8, 2.31.12, 2.32.2, and 2.33.3, `azureidentity.Validate()` verifies that the PKCS#7 signer certificate chains to a trusted Azure CA but never verifies the PKCS#7 signature itself. An attacker can embed a legitimate Azure certificate alongside arbitrary content e.g. `{"vmId":"<target>"}` and the forged `vmId` will be accepted returning the victim workspace agent's session token. No authentication is required. The attacker only needs to know a target VM's `vmId` which is a `UUIDv4`. That's a practical limitation which would typically require prior access to be exploited. Versions 2.24.5, 2.29.13, 2.30.8, 2.31.12, 2.32.2, and 2.33.3 patch the issue. As a workaround, reconfigure any Azure templates to use token authentication rather than `azure-instance-identity`.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2026-46354?

16 open source packages ship an affected version, including github.com/coder/coder/v2 and github.com/coder/coder. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/coder/coder/v2` | Go | All versions | 2.24.5, 2.29.13, 2.30.8, 2.31.12, 2.32.2, 2.33.3 |
| `github.com/coder/coder/v2` | Go | All versions | 2.24.5 |
| `github.com/coder/coder/v2` | Go | All versions | 2.24.5 |
| `github.com/coder/coder/v2` | Go | From 2.29.0 | 2.29.13 |
| `github.com/coder/coder/v2` | Go | From 2.29.0 | 2.29.13 |
| `github.com/coder/coder/v2` | Go | From 2.30.0 | 2.30.8 |
| `github.com/coder/coder/v2` | Go | From 2.30.0 | 2.30.8 |
| `github.com/coder/coder/v2` | Go | From 2.31.0 | 2.31.12 |
| `github.com/coder/coder/v2` | Go | From 2.31.0 | 2.31.12 |
| `github.com/coder/coder/v2` | Go | From 2.32.0-rc.0 | 2.32.2 |
| `github.com/coder/coder/v2` | Go | From 2.32.0-rc.0 | 2.32.2 |
| `github.com/coder/coder/v2` | Go | From 2.33.0-rc.0 | 2.33.3 |
| `github.com/coder/coder/v2` | Go | From 2.33.0-rc.0 | 2.33.3 |
| `github.com/coder/coder` | Go | All versions | None |
| `github.com/coder/coder` | Go | All versions to 0.27.3 | None |
| `github.com/coder/coder` | Go | All versions to 0.27.3 | None |

Products: Coder Coder.

## How do I fix CVE-2026-46354?

Upgrade github.com/coder/coder/v2 to a fixed version for your release line: 2.24.5, 2.29.13, 2.30.8 or 2.31.12.

## Is CVE-2026-46354 being exploited?

There is no known exploitation of CVE-2026-46354 in the wild and no public exploit code.

## Other vulnerabilities in coder

- [CVE-2026-55429](https://insights.sbomify.com/CVE-2026-55429/): Coder's workspace app upsert allows cross-workspace agent rebinding via user-controlled app ID (high 8.7)
- [CVE-2026-55427](https://insights.sbomify.com/CVE-2026-55427/): Coder vulnerable to SSH config injection via unsanitized server-supplied values in `coder config-ssh` (high 8.3)
- [CVE-2026-55428](https://insights.sbomify.com/CVE-2026-55428/): Coder: Route hijacking through lack of validation of agent-supplied AllowedIPs in tailnet coordinator (high 8.2)
- [CVE-2024-27918](https://insights.sbomify.com/CVE-2024-27918/): Coder's OIDC authentication allows email with partially matching domain to register (high 8.2)
- [CVE-2026-44454](https://insights.sbomify.com/CVE-2026-44454/): Coder vulnerable to workspace auto-creation via crafted URL parameters without user consent (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46354 and fix it if it is affected.

What it is: CVE-2026-46354 is a critical authentication bypass vulnerability in coder, published on 7 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-46354 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/coder/coder/v2 (Go): affected all versions; fixed in 2.24.5, 2.29.13, 2.30.8, 2.31.12, 2.32.2, 2.33.3
- github.com/coder/coder/v2 (Go): affected all versions; fixed in 2.24.5
- github.com/coder/coder/v2 (Go): affected all versions; fixed in 2.24.5
- github.com/coder/coder/v2 (Go): affected from 2.29.0; fixed in 2.29.13
- github.com/coder/coder/v2 (Go): affected from 2.29.0; fixed in 2.29.13
- github.com/coder/coder/v2 (Go): affected from 2.30.0; fixed in 2.30.8
- github.com/coder/coder/v2 (Go): affected from 2.30.0; fixed in 2.30.8
- github.com/coder/coder/v2 (Go): affected from 2.31.0; fixed in 2.31.12
- github.com/coder/coder/v2 (Go): affected from 2.31.0; fixed in 2.31.12
- github.com/coder/coder/v2 (Go): affected from 2.32.0-rc.0; fixed in 2.32.2
- github.com/coder/coder/v2 (Go): affected from 2.32.0-rc.0; fixed in 2.32.2
- github.com/coder/coder/v2 (Go): affected from 2.33.0-rc.0; fixed in 2.33.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46354/ (Markdown: https://insights.sbomify.com/CVE-2026-46354/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46354
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46354
- OSV: https://osv.dev/vulnerability/CVE-2026-46354

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46354/
Summaries are generated and may contain mistakes; the official description above is the record.
