# CVE-2026-46356: Fleet: IP spoofing allows bypassing API rate limiting

> Attackers can bypass API rate limits by spoofing IP headers, enabling brute-force attacks against Fleet instances exposed directly to the internet.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 May 2026
- **Updated:** 14 May 2026
- **Also known as:** GHSA-mxmp-wr3w-rvqx, GO-2026-5520

## What is CVE-2026-46356?

CVE-2026-46356 is a medium-severity vulnerability in fleetdm fleet, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fleet is open source device management software. Prior to version 4.80.1, a vulnerability in Fleet's IP extraction logic allows unauthenticated attackers to bypass API rate limiting by spoofing client IP headers. This may allow brute-force login attempts or other abuse against Fleet instances exposed to the public internet. Fleet extracted client IP addresses from request headers (`True-Client-IP`, `X-Real-IP`, `X-Forwarded-For`) without validating that those headers originate from a trusted proxy. The extracted IP is used as the key for rate limiting and IP ban decisions. As a result, an attacker could rotate the value of these headers on each request, causing Fleet to treat each attempt as coming from a different client. This effectively bypasses per-IP rate limits on sensitive endpoints such as the login API, enabling unrestricted brute-force or credential stuffing attacks. This issue primarily affects Fleet instances that are directly exposed to the internet without a reverse proxy that overwrites forwarded-IP headers. Instances behind a properly configured proxy or WAF are less affected. Version 4.80.1 contains a patch. If an immediate upgrade is not possible, administrators should ensure Fleet is deployed behind a reverse proxy (e.g., nginx, Cloudflare, AWS ALB) that overwrites `X-Forwarded-For` with the true client IP, and apply rate limiting at the proxy or WAF layer.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2026-46356?

3 open source packages ship an affected version, including github.com/fleetdm/fleet/v4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.80.1 |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.80.1 |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.80.1 |

Products: Fleetdm Fleet.

## How do I fix CVE-2026-46356?

Upgrade github.com/fleetdm/fleet/v4 to 4.80.1 or later.

## Is CVE-2026-46356 being exploited?

There is no known exploitation of CVE-2026-46356 in the wild and no public exploit code.

## Other vulnerabilities in fleetdm fleet

- [CVE-2020-26276](https://insights.sbomify.com/CVE-2020-26276/): SAML authentication vulnerability in Fleet (critical 10.0)
- [CVE-2026-103264](https://insights.sbomify.com/CVE-2026-103264/): Fleet before 4.87.0 Authentication Bypass via Device Identifiers (critical 9.3)
- [CVE-2026-23518](https://insights.sbomify.com/CVE-2026-23518/): Fleet has a JWT signature bypass vulnerability in Azure AD MDM enrollment (critical 9.3)
- [CVE-2026-26062](https://insights.sbomify.com/CVE-2026-26062/): Fleet server may terminate unexpectedly when handling certain gRPC requests (high 8.7)
- [CVE-2026-26061](https://insights.sbomify.com/CVE-2026-26061/): Fleet's unbounded request body read allows remote Denial of Service (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46356 and fix it if it is affected.

What it is: CVE-2026-46356 is a medium-severity vulnerability in fleetdm fleet, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-46356 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.80.1
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.80.1
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.80.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46356/ (Markdown: https://insights.sbomify.com/CVE-2026-46356/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46356
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46356
- OSV: https://osv.dev/vulnerability/CVE-2026-46356

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46356/
Summaries are generated and may contain mistakes; the official description above is the record.
