# CVE-2026-4636: Keycloak: keycloak: uma policy bypass allows authenticated users to gain unauthorized access to victim-owned resources.

> Authenticated users with uma_protection role can bypass UMA policy validation to access victim-owned resources and obtain sensitive information.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Apr 2026
- **Updated:** 15 Jul 2026
- **Also known as:** BIT-keycloak-2026-4636, ECHO-5dd9-eb24-e2ed, GHSA-f2hx-5fx3-hmcv, MINI-v8cr-2688-jhwf, MINI-vx69-qh8r-425r

## What is CVE-2026-4636?

CVE-2026-4636 is a high-severity missing authorization vulnerability in Redhat Build of Keycloak, published on 2 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was found in Keycloak. An authenticated user with the uma_protection role can bypass User-Managed Access (UMA) policy validation. This allows the attacker to include resource identifiers owned by other users in a policy creation request, even if the URL path specifies an attacker-owned resource. Consequently, the attacker gains unauthorized permissions to victim-owned resources, enabling them to obtain a Requesting Party Token (RPT) and access sensitive information or perform unauthorized actions.

Weakness: CWE-551 (Incorrect Behavior Order: Authorization Before Parsing and Canonicalization)

## Which versions are affected by CVE-2026-4636?

3 open source packages ship an affected version, including org.keycloak:keycloak-services and keycloak. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-services` | Maven | All versions | 26.5.7 |
| `org.keycloak:keycloak-services` | Maven | All versions | 26.5.7 |
| `keycloak` | Bitnami | From 26.2.0 | 26.2.1, 26.3.0, 26.4.1, 26.5.0 |

Products: Redhat Build of Keycloak.

## How do I fix CVE-2026-4636?

Upgrade org.keycloak:keycloak-services to 26.5.7 or later.

## Is CVE-2026-4636 being exploited?

There is no known exploitation of CVE-2026-4636 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Build of Keycloak

- [CVE-2026-15572](https://insights.sbomify.com/CVE-2026-15572/): Keycloak-services: keycloak-services: dcr protocol mapper type-swap policy bypass allows privilege escalation (high 8.8)
- [CVE-2026-3047](https://insights.sbomify.com/CVE-2026-3047/): Keycloak SAML Broken has Authentication Bypass by Primary Weakness (high 8.8)
- [CVE-2026-15573](https://insights.sbomify.com/CVE-2026-15573/): Keycloak-services: keycloak-services: authorization bypass via unnormalized uri matching in pathmatcher (high 8.1)
- [CVE-2026-16102](https://insights.sbomify.com/CVE-2026-16102/): Keycloak-services: keycloak-services: default dcr policy allows role forgery via user property mappers (high 8.1)
- [CVE-2026-1609](https://insights.sbomify.com/CVE-2026-1609/): Org.keycloak/keycloak-quarkus-server: keycloak: unauthorized access via jwt authorization grant with disabled users (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-4636 and fix it if it is affected.

What it is: CVE-2026-4636 is a high-severity missing authorization vulnerability in Redhat Build of Keycloak, published on 2 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-4636 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 26.5.7
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 26.5.7
- keycloak (Bitnami): affected from 26.2.0; fixed in 26.2.1, 26.3.0, 26.4.1, 26.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-4636/ (Markdown: https://insights.sbomify.com/CVE-2026-4636/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-4636
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-4636
- OSV: https://osv.dev/vulnerability/CVE-2026-4636

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-4636/
Summaries are generated and may contain mistakes; the official description above is the record.
