{"answers":{"affected":"4 open source packages ship an affected version, including thorsten/phpmyfaq and phpmyfaq/phpmyfaq.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46362 exists.","fix":"Upgrade thorsten/phpmyfaq to 4.1.2 or later.","what":"CVE-2026-46362 is a high-severity missing authorization vulnerability in thorsten phpmyfaq, published on 15 May 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-46362 and fix it if it is affected.\n\nWhat it is: CVE-2026-46362 is a high-severity missing authorization vulnerability in thorsten phpmyfaq, published on 15 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46362 exists.\n\nAffected packages and fixed versions:\n- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.1.2\n- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.1.2\n- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.1.2\n- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-46362/ (Markdown: https://insights.sbomify.com/CVE-2026-46362/index.md)","id":"CVE-2026-46362","markdown":"https://insights.sbomify.com/CVE-2026-46362/index.md","name":"CVE-2026-46362","record":{"aliases":["GHSA-hpgw-ww76-c68r"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"FAQ web application","requires_auth":"low_privilege","summary":"Authenticated attackers can bypass permission checks to access protected admin pages, exposing logs, user data, and system configuration.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"phpMyFAQ before 4.1.2 contains an authorization bypass vulnerability in AbstractAdministrationController::userHasPermission() that fails to terminate execution after sending a forbidden response. Attackers can access all permission-protected admin pages by requesting their URLs as authenticated users, exposing admin logs, user data, system information, and application configuration.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"phpMyFAQ - Authorization Bypass in Admin Pages via Non-Terminating Permission Check","id":"CVE-2026-46362","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":4,"n_references":2,"next":{"headline":"phpMyFAQ - Stored XSS in FAQ Question/Answer via Encode-Decode Bypass","id":"CVE-2026-46363"},"packages":[{"ecosystem":"Packagist","fixed":["4.1.2"],"introduced":["0"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":null,"source":"GHSA-hpgw-ww76-c68r"},{"ecosystem":"Packagist","fixed":["4.1.2"],"introduced":["0"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":"pkg:composer/phpmyfaq/phpmyfaq","source":"GHSA-hpgw-ww76-c68r"},{"ecosystem":"Packagist","fixed":["4.1.2"],"introduced":["0"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":null,"source":"GHSA-hpgw-ww76-c68r"},{"ecosystem":"Packagist","fixed":["4.1.2"],"introduced":["0"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":"pkg:composer/thorsten/phpmyfaq","source":"GHSA-hpgw-ww76-c68r"}],"prev":{"headline":"phpMyFAQ - Stored Cross-Site Scripting via raw Filter in search.twig","id":"CVE-2026-46361"},"products":["phpmyfaq"],"published":"2026-05-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-28","vendors":["thorsten"]},"summary":"Authenticated attackers can bypass permission checks to access protected admin pages, exposing logs, user data, and system configuration.","url":"https://insights.sbomify.com/CVE-2026-46362/"}