# CVE-2026-46362: phpMyFAQ - Authorization Bypass in Admin Pages via Non-Terminating Permission Check

> Authenticated attackers can bypass permission checks to access protected admin pages, exposing logs, user data, and system configuration.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 May 2026
- **Updated:** 28 May 2026
- **Also known as:** GHSA-hpgw-ww76-c68r

## What is CVE-2026-46362?

CVE-2026-46362 is a high-severity missing authorization vulnerability in thorsten phpmyfaq, published on 15 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

phpMyFAQ before 4.1.2 contains an authorization bypass vulnerability in AbstractAdministrationController::userHasPermission() that fails to terminate execution after sending a forbidden response. Attackers can access all permission-protected admin pages by requesting their URLs as authenticated users, exposing admin logs, user data, system information, and application configuration.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-46362?

4 open source packages ship an affected version, including thorsten/phpmyfaq and phpmyfaq/phpmyfaq.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `thorsten/phpmyfaq` | Packagist | All versions | 4.1.2 |
| `thorsten/phpmyfaq` | Packagist | All versions | 4.1.2 |
| `phpmyfaq/phpmyfaq` | Packagist | All versions | 4.1.2 |
| `phpmyfaq/phpmyfaq` | Packagist | All versions | 4.1.2 |

## How do I fix CVE-2026-46362?

Upgrade thorsten/phpmyfaq to 4.1.2 or later.

## Is CVE-2026-46362 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46362 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46362 and fix it if it is affected.

What it is: CVE-2026-46362 is a high-severity missing authorization vulnerability in thorsten phpmyfaq, published on 15 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46362 exists.

Affected packages and fixed versions:
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.1.2
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.1.2
- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.1.2
- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46362/ (Markdown: https://insights.sbomify.com/CVE-2026-46362/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46362
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46362
- OSV: https://osv.dev/vulnerability/CVE-2026-46362

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46362/
Summaries are generated and may contain mistakes; the official description above is the record.
