{"answers":{"affected":"4 open source packages ship an affected version, including thorsten/phpmyfaq and phpmyfaq/phpmyfaq.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46363 exists.","fix":"Upgrade thorsten/phpmyfaq to 4.1.2 or later.","what":"CVE-2026-46363 is a medium-severity cross-site scripting vulnerability in thorsten phpmyfaq, published on 15 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-46363 and fix it if it is affected.\n\nWhat it is: CVE-2026-46363 is a medium-severity cross-site scripting vulnerability in thorsten phpmyfaq, published on 15 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46363 exists.\n\nAffected packages and fixed versions:\n- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.1.2\n- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.1.2\n- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.1.2\n- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-46363/ (Markdown: https://insights.sbomify.com/CVE-2026-46363/index.md)","id":"CVE-2026-46363","markdown":"https://insights.sbomify.com/CVE-2026-46363/index.md","name":"CVE-2026-46363","record":{"aliases":["GHSA-f5p7-2c9q-8896"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"FAQ web application","requires_auth":"low_privilege","summary":"Authenticated attackers can inject malicious scripts into FAQ content, leading to script execution in visitors' browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"phpMyFAQ before 4.1.2 contains a stored cross-site scripting vulnerability in FAQ creation and update endpoints that bypass sanitization through encode-decode cycles. The vulnerability allows authenticated attackers with FAQ_ADD permission to inject malicious script tags via question or answer parameters, which execute in every visitor's browser when FAQ content is rendered with the raw Twig filter.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"phpMyFAQ - Stored XSS in FAQ Question/Answer via Encode-Decode Bypass","id":"CVE-2026-46363","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":4,"n_references":2,"next":{"headline":"phpMyFAQ - SQL Injection via User-Agent Header in BuiltinCaptcha","id":"CVE-2026-46364"},"packages":[{"ecosystem":"Packagist","fixed":["4.1.2"],"introduced":["0"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":null,"source":"GHSA-f5p7-2c9q-8896"},{"ecosystem":"Packagist","fixed":["4.1.2"],"introduced":["0"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":"pkg:composer/phpmyfaq/phpmyfaq","source":"GHSA-f5p7-2c9q-8896"},{"ecosystem":"Packagist","fixed":["4.1.2"],"introduced":["0"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":null,"source":"GHSA-f5p7-2c9q-8896"},{"ecosystem":"Packagist","fixed":["4.1.2"],"introduced":["0"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":"pkg:composer/thorsten/phpmyfaq","source":"GHSA-f5p7-2c9q-8896"}],"prev":{"headline":"phpMyFAQ - Authorization Bypass in Admin Pages via Non-Terminating Permission Check","id":"CVE-2026-46362"},"products":["phpmyfaq"],"published":"2026-05-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-28","vendors":["thorsten"]},"summary":"Authenticated attackers can inject malicious scripts into FAQ content, leading to script execution in visitors' browsers.","url":"https://insights.sbomify.com/CVE-2026-46363/"}