# CVE-2026-46363: phpMyFAQ - Stored XSS in FAQ Question/Answer via Encode-Decode Bypass

> Authenticated attackers can inject malicious scripts into FAQ content, leading to script execution in visitors' browsers.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 May 2026
- **Updated:** 28 May 2026
- **Also known as:** GHSA-f5p7-2c9q-8896

## What is CVE-2026-46363?

CVE-2026-46363 is a medium-severity cross-site scripting vulnerability in thorsten phpmyfaq, published on 15 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

phpMyFAQ before 4.1.2 contains a stored cross-site scripting vulnerability in FAQ creation and update endpoints that bypass sanitization through encode-decode cycles. The vulnerability allows authenticated attackers with FAQ_ADD permission to inject malicious script tags via question or answer parameters, which execute in every visitor's browser when FAQ content is rendered with the raw Twig filter.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-46363?

4 open source packages ship an affected version, including thorsten/phpmyfaq and phpmyfaq/phpmyfaq.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `thorsten/phpmyfaq` | Packagist | All versions | 4.1.2 |
| `thorsten/phpmyfaq` | Packagist | All versions | 4.1.2 |
| `phpmyfaq/phpmyfaq` | Packagist | All versions | 4.1.2 |
| `phpmyfaq/phpmyfaq` | Packagist | All versions | 4.1.2 |

## How do I fix CVE-2026-46363?

Upgrade thorsten/phpmyfaq to 4.1.2 or later.

## Is CVE-2026-46363 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46363 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46363 and fix it if it is affected.

What it is: CVE-2026-46363 is a medium-severity cross-site scripting vulnerability in thorsten phpmyfaq, published on 15 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46363 exists.

Affected packages and fixed versions:
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.1.2
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.1.2
- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.1.2
- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46363/ (Markdown: https://insights.sbomify.com/CVE-2026-46363/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46363
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46363
- OSV: https://osv.dev/vulnerability/CVE-2026-46363

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46363/
Summaries are generated and may contain mistakes; the official description above is the record.
