# CVE-2026-46365: phpMyFAQ - Missing Authorization in Tag Deletion Endpoint

> Authenticated users can delete arbitrary tags in phpMyFAQ due to missing authorization checks, causing permanent data loss.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 May 2026
- **Updated:** 28 May 2026
- **Also known as:** GHSA-7cx3-2qx2-3g6w

## What is CVE-2026-46365?

CVE-2026-46365 is a medium-severity missing authorization vulnerability in thorsten phpmyfaq, published on 15 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

phpMyFAQ before 4.1.2 contains a missing authorization vulnerability in the DELETE /admin/api/content/tags/{tagId} endpoint that allows any authenticated user to delete tags. Any logged-in user, including regular frontend users, can delete arbitrary tags by sending a DELETE request with a valid session cookie, resulting in permanent data loss and disruption of FAQ organization.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-46365?

4 open source packages ship an affected version, including thorsten/phpmyfaq and phpmyfaq/phpmyfaq.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `thorsten/phpmyfaq` | Packagist | All versions | 4.1.2 |
| `thorsten/phpmyfaq` | Packagist | All versions | 4.1.2 |
| `phpmyfaq/phpmyfaq` | Packagist | All versions | 4.1.2 |
| `phpmyfaq/phpmyfaq` | Packagist | All versions | 4.1.2 |

## How do I fix CVE-2026-46365?

Upgrade thorsten/phpmyfaq to 4.1.2 or later.

## Is CVE-2026-46365 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46365 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46365 and fix it if it is affected.

What it is: CVE-2026-46365 is a medium-severity missing authorization vulnerability in thorsten phpmyfaq, published on 15 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46365 exists.

Affected packages and fixed versions:
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.1.2
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.1.2
- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.1.2
- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46365/ (Markdown: https://insights.sbomify.com/CVE-2026-46365/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46365
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46365
- OSV: https://osv.dev/vulnerability/CVE-2026-46365

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46365/
Summaries are generated and may contain mistakes; the official description above is the record.
