# CVE-2026-46366: phpMyFAQ - Unauthenticated Information Disclosure via getIdFromSolutionId Permission Bypass

> Unauthenticated attackers can enumerate restricted FAQ entries and read their titles by bypassing permission checks in the getIdFromSolutionId method.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 May 2026
- **Updated:** 28 May 2026
- **Also known as:** GHSA-99qv-g4x9-mgc3

## What is CVE-2026-46366?

CVE-2026-46366 is a high-severity missing authorization vulnerability in thorsten phpmyfaq, published on 15 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

phpMyFAQ before 4.1.2 contains an information disclosure vulnerability in the getIdFromSolutionId() method that lacks permission filtering, allowing unauthenticated attackers to enumerate restricted FAQ entries and read their titles via the /solution_id_{id}.html endpoint. Attackers can sequentially iterate solution IDs to discover all FAQs including those restricted to specific users or groups, leaking sensitive metadata through redirect Location headers and page canonical links.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-46366?

4 open source packages ship an affected version, including thorsten/phpmyfaq and phpmyfaq/phpmyfaq.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `thorsten/phpmyfaq` | Packagist | All versions | 4.1.2 |
| `thorsten/phpmyfaq` | Packagist | All versions | 4.1.2 |
| `phpmyfaq/phpmyfaq` | Packagist | All versions | 4.1.2 |
| `phpmyfaq/phpmyfaq` | Packagist | All versions | 4.1.2 |

## How do I fix CVE-2026-46366?

Upgrade thorsten/phpmyfaq to 4.1.2 or later.

## Is CVE-2026-46366 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46366 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46366 and fix it if it is affected.

What it is: CVE-2026-46366 is a high-severity missing authorization vulnerability in thorsten phpmyfaq, published on 15 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46366 exists.

Affected packages and fixed versions:
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.1.2
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.1.2
- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.1.2
- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46366/ (Markdown: https://insights.sbomify.com/CVE-2026-46366/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46366
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46366
- OSV: https://osv.dev/vulnerability/CVE-2026-46366

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46366/
Summaries are generated and may contain mistakes; the official description above is the record.
