{"answers":{"affected":"4 open source packages ship an affected version, including thorsten/phpmyfaq and phpmyfaq/phpmyfaq.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46367 exists.","fix":"Upgrade thorsten/phpmyfaq to 4.1.2 or later.","what":"CVE-2026-46367 is a high-severity cross-site scripting vulnerability in thorsten phpmyfaq, published on 15 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-46367 and fix it if it is affected.\n\nWhat it is: CVE-2026-46367 is a high-severity cross-site scripting vulnerability in thorsten phpmyfaq, published on 15 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46367 exists.\n\nAffected packages and fixed versions:\n- thorsten/phpmyfaq (Packagist): affected from 4.1.1; fixed in 4.1.2\n- thorsten/phpmyfaq (Packagist): affected from 4.1.1; fixed in 4.1.2\n- phpmyfaq/phpmyfaq (Packagist): affected from 4.1.1; fixed in 4.1.2\n- phpmyfaq/phpmyfaq (Packagist): affected from 4.1.1; fixed in 4.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-46367/ (Markdown: https://insights.sbomify.com/CVE-2026-46367/index.md)","id":"CVE-2026-46367","markdown":"https://insights.sbomify.com/CVE-2026-46367/index.md","name":"CVE-2026-46367","record":{"aliases":["GHSA-9525-27vj-c8r8"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"FAQ web application","requires_auth":"low_privilege","summary":"Authenticated users can inject JavaScript via malformed URLs in comments, leading to admin session theft and application takeover.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.3,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:L/VA:N/SC:H/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"phpMyFAQ before 4.1.2 contains a stored cross-site scripting vulnerability in Utils::parseUrl() that allows authenticated users to inject JavaScript via malformed URLs in comments. Attackers can craft URLs with unescaped quotes to inject event handlers, stealing admin session cookies and achieving full application takeover when visitors view affected FAQ pages.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"phpMyFAQ - Stored XSS via Utils::parseUrl() in Comment Rendering","id":"CVE-2026-46367","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":4,"n_references":2,"next":{"headline":"luci-app-https-dns-proxy Authenticated Command Injection via setInitAction","id":"CVE-2026-46368"},"packages":[{"ecosystem":"Packagist","fixed":["4.1.2"],"introduced":["4.1.1"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":null,"source":"GHSA-9525-27vj-c8r8"},{"ecosystem":"Packagist","fixed":["4.1.2"],"introduced":["4.1.1"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":"pkg:composer/phpmyfaq/phpmyfaq","source":"GHSA-9525-27vj-c8r8"},{"ecosystem":"Packagist","fixed":["4.1.2"],"introduced":["4.1.1"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":null,"source":"GHSA-9525-27vj-c8r8"},{"ecosystem":"Packagist","fixed":["4.1.2"],"introduced":["4.1.1"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":"pkg:composer/thorsten/phpmyfaq","source":"GHSA-9525-27vj-c8r8"}],"prev":{"headline":"phpMyFAQ - Unauthenticated Information Disclosure via getIdFromSolutionId Permission Bypass","id":"CVE-2026-46366"},"products":["phpmyfaq"],"published":"2026-05-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-28","vendors":["thorsten"]},"summary":"Authenticated users can inject JavaScript via malformed URLs in comments, leading to admin session theft and application takeover.","url":"https://insights.sbomify.com/CVE-2026-46367/"}