# CVE-2026-46372: SillyTavern: SSRF in SearXNG Search Proxy via Unvalidated baseUrl

> An authenticated user can exploit an unvalidated baseUrl parameter in the SearXNG search proxy to perform Server-Side Request Forgery and read internal service responses.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 May 2026
- **Updated:** 29 May 2026
- **Also known as:** GHSA-qg89-qwwh-5f3j

## What is CVE-2026-46372?

CVE-2026-46372 is a high-severity server-side request forgery vulnerability in SillyTavern, published on 29 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

SillyTavern is a locally installed user interface that allows users to interact with text generation large language models, image generation engines, and text-to-speech voice models. Prior to 1.18.0, SillyTavern exposes /api/search/searxng, which accepts attacker-controlled baseUrl and uses it directly to build outbound server-side fetches. An authenticated low-privilege user can point baseUrl at an internal or loopback HTTP service and receive the /search response body. This vulnerability is fixed in 1.18.0.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-46372?

2 open source packages ship an affected version, including sillytavern.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sillytavern` | npm | All versions | 1.18.0 |
| `sillytavern` | npm | All versions | 1.18.0 |

## How do I fix CVE-2026-46372?

Upgrade sillytavern to 1.18.0 or later.

## Is CVE-2026-46372 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46372 exists.

Public exploit code:

- SillyTavern - Server-Side Request Forgery (nuclei): http/cves/2026/CVE-2026-46372.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46372 and fix it if it is affected.

What it is: CVE-2026-46372 is a high-severity server-side request forgery vulnerability in SillyTavern, published on 29 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46372 exists.

Affected packages and fixed versions:
- sillytavern (npm): affected all versions; fixed in 1.18.0
- sillytavern (npm): affected all versions; fixed in 1.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46372/ (Markdown: https://insights.sbomify.com/CVE-2026-46372/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46372
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46372
- OSV: https://osv.dev/vulnerability/CVE-2026-46372

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46372/
Summaries are generated and may contain mistakes; the official description above is the record.
