{"answers":{"affected":"3 open source packages ship an affected version, including sqlfluff. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-46373 in the wild and no public exploit code.","fix":"Upgrade sqlfluff to 4.1.0 or later.","what":"CVE-2026-46373 is a high-severity denial of service vulnerability in sqlfluff, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-46373 and fix it if it is affected.\n\nWhat it is: CVE-2026-46373 is a high-severity denial of service vulnerability in sqlfluff, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-46373 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sqlfluff (PyPI): affected all versions; fixed in 4.1.0\n- sqlfluff (PyPI): affected all versions; fixed in 4.1.0\n- sqlfluff (PyPI): affected all versions; fixed in 4.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-46373/ (Markdown: https://insights.sbomify.com/CVE-2026-46373/index.md)","id":"CVE-2026-46373","markdown":"https://insights.sbomify.com/CVE-2026-46373/index.md","name":"CVE-2026-46373","record":{"aliases":["DEBIAN-CVE-2026-46373","GHSA-wmhf-fqc8-vxhh","PYSEC-2026-209","UBUNTU-CVE-2026-46373"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"SQL linter library","requires_auth":"none","summary":"An attacker can cause a denial of service in applications using SQLFluff by submitting SQL queries with excessive nesting, triggering a stack overflow.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"sqlfluff","vendor":"sqlfluff"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"}],"description":"SQLFluff is a modular SQL linter and auto-formatter with support for multiple dialects and templated code. Prior to version 4.1.0, in deployments where untrusted users can provide SQL queries to be linted, an untrusted user can submit a malicious query with deliberate excessive nesting to any application using the parser to trigger a Denial of Service through resource exhaustion. This issue has been patched in version 4.1.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"SQLFluff: Recursive Stack Overflow in Parser","id":"CVE-2026-46373","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":3,"n_references":1,"next":{"headline":"SQLFluff: Uncontrolled Resource Consumption in Parser","id":"CVE-2026-46374"},"packages":[{"ecosystem":"PyPI","fixed":["4.1.0"],"introduced":["0"],"last_affected":[],"package":"sqlfluff","purl":null,"source":"GHSA-wmhf-fqc8-vxhh"},{"ecosystem":"PyPI","fixed":["4.1.0"],"introduced":["0"],"last_affected":[],"package":"sqlfluff","purl":"pkg:pypi/sqlfluff","source":"GHSA-wmhf-fqc8-vxhh"},{"ecosystem":"PyPI","fixed":["4.1.0"],"introduced":["0"],"last_affected":[],"package":"sqlfluff","purl":"pkg:pypi/sqlfluff","source":"PYSEC-2026-209"}],"prev":{"headline":"SillyTavern: SSRF in SearXNG Search Proxy via Unvalidated baseUrl","id":"CVE-2026-46372"},"products":["sqlfluff"],"published":"2026-06-09","related":[{"cvss_score":7.5,"headline":"SQLFluff: Uncontrolled Resource Consumption in Parser","id":"CVE-2026-46374","kev_date_added":null,"published":"2026-06-09"},{"cvss_score":6.3,"headline":"SQLFluff vulnerability for users with access to config file, using `library_path` to call arbitrary python code.","id":"CVE-2023-36830","kev_date_added":null,"published":"2023-07-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-10","vendors":["sqlfluff"]},"summary":"An attacker can cause a denial of service in applications using SQLFluff by submitting SQL queries with excessive nesting, triggering a stack overflow.","url":"https://insights.sbomify.com/CVE-2026-46373/"}