CVE-2026-46380 compliance-trestle Vulnerable to SSRF in Remote Fetching Subsystem
An attacker can exploit Server-Side Request Forgery in compliance-trestle to access internal services or cloud metadata endpoints.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-46380?
CVE-2026-46380 is a medium-severity server-side request forgery vulnerability in oscal-compass compliance-trestle, published on 14 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
compliance-trestle is a tooling platform for managing compliance as code. Prior to versions 3.12.2 and 4.0.3, the HTTPSFetcher._do_fetch() method passes a user-supplied URL directly to requests.get() without validation. This allows an attacker to perform Server-Side Request Forgery, targeting internal services or cloud metadata endpoints. Versions 3.12.2 and 4.0.3 fix the issue.
Weakness: CWE-918
Which versions are affected by CVE-2026-46380?
5 open source packages ship an affected version, including compliance-trestle.
| Package | Affected | Fixed in |
|---|---|---|
compliance-trestle PyPI | All versions | 3.12.2, 4.0.3 |
compliance-trestle PyPI | All versions | 3.12.2 |
compliance-trestle PyPI | All versions | 3.12.2 |
compliance-trestle PyPI | From 4.0.0 | 4.0.3 |
compliance-trestle PyPI | From 4.0.0 | 4.0.3 |
How do I fix CVE-2026-46380?
Upgrade compliance-trestle to a fixed version for your release line: 3.12.2 or 4.0.3.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2026-46380 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46380 exists.
Sources
Also known as GHSA-w76h-q7c6-jpjp, PYSEC-2026-2427.